Bug 725841 - m-i-t: please drop needless and partly incorrect config files
Summary: m-i-t: please drop needless and partly incorrect config files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: module-init-tools
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jon Masters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 676095 (view as bug list)
Depends On:
Blocks: 734884
TreeView+ depends on / blocked
 
Reported: 2011-07-26 17:47 UTC by Kay Sievers
Modified: 2011-08-31 18:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 18:38:55 UTC


Attachments (Terms of Use)

Description Kay Sievers 2011-07-26 17:47:00 UTC
Hey Jon,

please drop:
  /etc/modprobe.d/dist-alsa.conf
  /etc/modprobe.d/dist-oss.conf
They are not needed anymore.

Please drop:
  /etc/modprobe.d/dist.conf
It's totally outdated, has a lot of no longer useful things in it.
If any, the remaining stuff belongs into the kernel modules, not as
paper-over in userspace config.

If needed, I can take care to add that to the kernel, if anything
in that list is really needed.

Please move:
  /etc/modprobe.d/blacklist.conf
to:
  /lib/modprobe.d/blacklist.conf
Admins should be able to mask the file with their own file in /etc.

Also please remove the /usr/local/ thing from the upstream code,
no early boot tool should look in /usr/local.

Thanks!

Comment 1 Lennart Poettering 2011-07-29 01:41:48 UTC
Oh, and please also make sure to add /lib/modprobe.d to the dirs owned by m-i-t, so that other packages can drop files in there, if they need to.

Comment 2 Lennart Poettering 2011-07-29 03:00:02 UTC
*** Bug 676095 has been marked as a duplicate of this bug. ***

Comment 3 Kay Sievers 2011-08-09 00:42:57 UTC
Jon, please fix these issues. Thanks!

Comment 4 Jon Masters 2011-08-11 22:24:43 UTC
Thanks for the ping. This bug was assigned to another account and I fixed that. I'll take a look (but note I am out of the office Mon-Wed next week).

Comment 5 Kay Sievers 2011-08-31 00:16:10 UTC
Ping again! It's getting boring.

Comment 6 Lennart Poettering 2011-08-31 00:16:26 UTC
Ping Ping!

Comment 7 Jon Masters 2011-08-31 18:18:56 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=3316321

I've built fixes for this stuff. You will need to get hwdata changed since it owns the blacklist.conf file (for historical reasons) to move it to /lib/modprobe.d rather than /etc/modprobe.d.

Jon.

Comment 8 Jon Masters 2011-08-31 18:38:27 UTC
See also 734884. Make sure you ping him every ten minutes like you do me.


Note You need to log in before you can comment on or make changes to this bug.