Bug 725883 - NPE in config masking utility
NPE in config masking utility
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
4.1
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On:
Blocks: rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-07-26 16:34 EDT by Heiko W. Rupp
Modified: 2014-06-30 08:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-30 08:24:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2011-07-26 16:34:45 EDT
Caused by: java.lang.NullPointerException
        at org.rhq.enterprise.server.configuration.util.ConfigurationMaskingUtility.unmaskProperty(ConfigurationMaskingUtility.java:151)
        at org.rhq.enterprise.server.configuration.util.ConfigurationMaskingUtility.unmaskPropertyMap(ConfigurationMaskingUtility.java:182)

when deploying a plugin with additional entries in the PD.
Comment 1 Ian Springer 2011-08-16 15:53:30 EDT
Heiko, can you clarify what you mean by "deploying a plugin with additional entries in the PD"?
Comment 2 Heiko W. Rupp 2011-08-16 16:13:30 EDT
I think this meant "additional set of properties to what have been there before".
But then I have seen this exactly once so far.
Comment 3 Ian Springer 2011-08-17 10:20:03 EDT
[master d4bf16e] should fix this (http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commit;h=d4bf16e).
Comment 4 Mike Foley 2011-08-24 14:45:04 EDT
verification steps would be:
1) updating a plugin's descriptor and adding some new props to its plugin config def
2) redeploying the plugin
3) seeing if you can view a plugin config on a resource of that type in the gui w/ no exceptions

Heiko .... as you are already working on the AS7 plug-in, and there is not enough information in this BZ for me to work with, perhaps you can verify?
Comment 5 Charles Crouch 2012-07-09 13:18:03 EDT
With Heiko to verify
Comment 6 Heiko W. Rupp 2014-06-30 08:24:05 EDT
I am closing this, as the code is in production for a long time and is apparently fixed.

Note You need to log in before you can comment on or make changes to this bug.