Bug 72589 - configuration of man erratic/wrong
configuration of man erratic/wrong
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-25 17:42 EDT by Michal Jaegermann
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 23:46:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-08-25 17:42:30 EDT
Description of Problem:

There are assorted problems with how 'man' configuration is handled.
It starts with this fragment of 'man man':

              Specify  the  configuration  file  to  use;   the   default   is
              /usr//etc/man.config.  (See man.conf(5).)

Interestingly enough there is no "see man.conf".  There is 'man man.config'
and this one for a change says:

FILES
       @man_config_file@

Ahem...

Checking with 'strace' what is actually consulted we can see

open("/usr//etc/man.config", O_RDONLY)  = -1 ENOENT (No such file or directory)

and this even includes "//" as 'man man' says.  It is true that this is
followed by attempts to open "/etc/man.conf" and "/etc/man.config" but the
content of the later seems to be taken into account or ignored depending
on some circumstances I cannot figure out.  In particular PAGER used may
end up either as '/usr/bin/less -isr', with output looking ok, or as
'/usr/bin/less -n' which will display escape sequences on a terminal.
A workaround for that is to set MANPAGER variable in an enviroment.

Further we can see in /etc/man.config

MANPATH /usr/local/man
MANPATH_MAP     /usr/local/bin          /usr/local/man
MANPATH_MAP     /usr/local/sbin         /usr/local/man

where /usr/local/man does not exist for quite a while replaced with
/usr/local/share/man.

And there is also this comment:

# NROFF is defined as "groff -Tascii" or "groff -Tlatin1";
# not only is it superfluous, but it actually damages the output.
# For use with utf-8, NROFF should be "nroff -mandoc" without -T option.

Is this indeed correct and a reason why non-English man pages are coming
mangled?
Comment 1 Michal Jaegermann 2002-08-25 18:07:44 EDT
A note: 'su - $(whoami)' seems to catch configuration changes if they are
otherwise missing.  But what is a reason for that I have no idea.
Comment 2 Eido Inoue 2003-01-13 23:46:09 EST
/usr/local/man changed to /usr/local/share/man in man-1.5k-2.

Will close as the nroff and man man are addressed in other bugs

Note You need to log in before you can comment on or make changes to this bug.