Bug 72592 - man and internationalization
man and internationalization
Status: CLOSED DUPLICATE of bug 71130
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-25 18:02 EDT by Michal Jaegermann
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-08-25 18:02:35 EDT
Description of Problem:

After installing packages 'man-pages-pl' and 'man-pages-ru'  I tried few
experiments. With pages which actually exist in a given language version
and using commands like

( env LANG=pl_PL man sort )
( env LANG=ru_RU man cp )

I got results which ranged between mangled and ridiculously unreadable.
OTOH correcting that to:

( env LANG=pl_PL man sort | iconv -f latin2  | less -isr)
( env LANG=ru_RU man cp | iconv -f koi8  | less -isr)

I got on a console what was actually expected.  Does this has anything to
do with options to nroff (see #72598)?

Curiously enough '( env LANG=pl_PL man sort | iconv -f latin2  | less -isr)'
displays correctly also in a gnome-terminal window where without 'iconv'
an output is garbled in not a very funny way.  No such luck there with Russian
version which is beyond anything even remotely readable even when "Russian"
session is started.  I guess that the later is caused by fonts which miss
pieces in a required encoding but current way of doing things makes this
information unavailable and a setup extremely confusing.
Comment 1 Tim Waugh 2003-02-06 05:41:04 EST
Please re-test the current rawhide versions of groff and less, in which several
bugs in this area have been fixed.
Comment 2 Jay Turner 2003-02-07 08:25:00 EST

*** This bug has been marked as a duplicate of 71130 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.