Bug 725942 - roundcubemail-0.5.3-1 requires php-pear-Net-IDNA2, which is not available
Summary: roundcubemail-0.5.3-1 requires php-pear-Net-IDNA2, which is not available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: roundcubemail
Version: el6
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 651897
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-27 04:51 UTC by Greg Smith
Modified: 2012-01-05 20:35 UTC (History)
11 users (show)

Fixed In Version: php-pear-Net-IDNA2-0.1.1-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-05 20:35:27 UTC


Attachments (Terms of Use)
Patch for spec file (1.43 KB, patch)
2011-09-26 13:32 UTC, Jos Vos
no flags Details | Diff
Source file patch (858 bytes, patch)
2011-09-26 13:33 UTC, Jos Vos
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 651897 None None None Never

Description Greg Smith 2011-07-27 04:51:15 UTC
Description of problem:
The current version of roundcube email web server will not install (or update) as it depends on a package that is not available in the EPEL repo.

The roundcube package requires php-pear-Net-IDNA2 -- which is not available in the repo.  The following was the result of trying to upgrade the package:

--> Finished Dependency Resolution
Error: Package: roundcubemail-0.5.3-1.el6.noarch (epel)
           Requires: php-pear-Net-IDNA2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):
0.5.3-1

How reproducible:
always

Steps to Reproduce:
yum install roundcubemail
yum install php-pear-Net-IDNA2      (attempt to install dependency)

Comment 1 Gwyn Ciesla 2011-07-27 12:39:18 UTC
Good news:  I branched php-pear-Net-IDNA2 for EL-6.  Bad news, it needs php-pear >= 1.9.1, the EL-6 version is 1.9.0.  And it's in RHEL, not EPEL, so I can't just check with the maintainer and bump it.

https://bugzilla.redhat.com/show_bug.cgi?id=726055

Comment 2 Greg Smith 2011-07-28 15:01:52 UTC
Should the previous roundcube be returned to the EL6 repo until the dependencies can be corrected?

It seems doubtful that RedHat will be quick to update php-pear, so a broken package could be sitting in the EL6 repo for a long time when the previous package worked OK.

Comment 3 Bill McGonigle 2011-08-19 03:57:43 UTC
(In reply to comment #1)
> Good news:  I branched php-pear-Net-IDNA2 for EL-6.  Bad news, it needs
> php-pear >= 1.9.1, the EL-6 version is 1.9.0.

Does it actually need 1.9.1?  As an experiment, I downloaded the f14 SRPM, built it on EL6 with the Requires: changed to 1.9.0, and it installed just fine.  Roundcubemail then installed fine.  I didn't see anything in the -IDNA2 changelog about why it thought 1.9.1 was needed.  I don't see anything that jumps out in the pear changelog either: http://pear.php.net/package/PEAR/download/1.9.1

I've tried sending myself a punycode link, and that works, but I don't know where all the code paths are.  I don't think I have a way to test a punycode e-mail.

It looks like php-pear 1.9.4 might be ON_QA for RHEL 6.1 updates.  I don't have permission to see the blocker, so it could be in 6.2 also.  That would be a drag for our EPEL users who are on a downstream distro.

If php-pear 1.9.0 will suffice, issuing an update for -IDNA2 with an updated Requires: might be the smoothest way forward.

Comment 4 Jos Vos 2011-09-13 10:40:02 UTC
Is there any progress on what will be done to solve this problem?

BTW what the impact of installing it without php-pear-net-IDNA2?

Comment 5 Greg Smith 2011-09-17 20:00:24 UTC
Just adding current bug which is tracking update to pear 1.9.1, as the other URL listed in this bug was marked duplicate.  

https://bugzilla.redhat.com/show_bug.cgi?id=651897

Comment 6 Jos Vos 2011-09-26 13:32:47 UTC
Created attachment 524907 [details]
Patch for spec file

Patch part 1/2 (spec file) to make this version of roundcubemail work on RHEL6 but WITHOUT IDNA support.

Comment 7 Jos Vos 2011-09-26 13:33:39 UTC
Created attachment 524908 [details]
Source file patch

Patch part 2/2 (source patch) to make this version of roundcubemail work on RHEL6 but WITHOUT IDNA support.

Comment 8 Jos Vos 2011-09-26 13:38:53 UTC
As I wanted to use roundcubemail on RHEL6 (i.e. SL 6.1) I patched it for my own use so that the PHP IDNA2 stuff is not used anymore (thus disabling IDNA2 support).

AFAICS this should work (it actually does generate with mock and runs fine at first sight), but I'm not a PHP expert, so please review the patch.

Comment 9 Greg Smith 2011-10-20 19:46:10 UTC
Hi Jos Vos:

Would it be possible to attach the patched and build RPM here?  

I can help test too, but unfortunately I don't have much skill at building RPMs from source.

The others watching this bug report could also try it, for confirmation.  

Thanks,
Greg

Comment 10 Edouard Bourguignon 2011-12-17 13:43:28 UTC
Any news?

Comment 11 Greg Smith 2011-12-17 20:16:24 UTC
Now that pear has been updated, the php-pear-Net-IDNA2 no longer appears to be available in the repo.

I tried to update roundcubemail, and got this error:


--> Processing Dependency: php-pear-Net-IDNA2 for package: roundcubemail-0.5.4-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: roundcubemail-0.5.4-1.el6.noarch (epel)
           Requires: php-pear-Net-IDNA2


Should the Net-IDNA2 package be available automatically now that the version of pear has been updated?

Comment 12 Greg Smith 2011-12-17 20:23:27 UTC
Looking, I think that the php-pear-Net-IDNA2 package was never added to the EL6 repo.

Now that pear has been upgraded to 1.9.4, it should be possible to add it.


Jon Cielsa -- would it be possible for you to add the previously ported Net-IDNA2 package to the repo?  I think that would now put the pieces in place to resolve this bug.

Comment 13 Gwyn Ciesla 2011-12-19 16:17:55 UTC
Built, will Bodhi.

Comment 14 Fedora Update System 2011-12-19 16:19:51 UTC
php-pear-Net-IDNA2-0.1.1-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-pear-Net-IDNA2-0.1.1-3.el6

Comment 15 Fedora Update System 2011-12-20 20:03:31 UTC
php-pear-Net-IDNA2-0.1.1-3.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 16 Greg Smith 2011-12-31 04:47:35 UTC
I enabled the EPEL 6 testing repo, but I'm not seeing IDNA come in or be available.

I'm not sure what's wrong  -- I just don't see it as being available (I do see several other php-pear packages that are only available in the EPEL testing repo)

Anyone else have problems?

Comment 17 Greg Smith 2011-12-31 05:28:12 UTC
Never mind -- I figured out my problem with the testing repo.

Installed INDA2, and then upgraded roundcube.  It seems to all install and work now -- on first try it still allowed me to log in.

I'm resetting my databases, and merging config files, to make sure I'm taking advantage of any new features.

Once INDA2 is in the regular repo, this bug can be closed completely.

now, I think I need to create another feature request to update the current roundcube level.

Comment 18 Fedora Update System 2012-01-05 20:35:27 UTC
php-pear-Net-IDNA2-0.1.1-3.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.