Bug 72595 - Evolution-addressbook crashes while adding/modifying contacts
Evolution-addressbook crashes while adding/modifying contacts
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-25 18:19 EDT by louisgtwo
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-09 21:50:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2002-08-25 18:19:57 EDT
I have a backtrace but I don't think is very useful.


[louisg00@tiger louisg00]$ gdb /usr/bin/evolution

GNU gdb Red Hat Linux (5.2.1-2)

Copyright 2002 Free Software Foundation, Inc.

GDB is free software, covered by the GNU General Public License, and you are

welcome to change it and/or distribute copies of it under certain conditions.

Type "show copying" to see the conditions.

There is absolutely no warranty for GDB.  Type "show warranty" for details.

This GDB was configured as "i386-redhat-linux"...

(no debugging symbols found)...

(gdb) run

Starting program: /usr/bin/evolution 

[New Thread 1024 (LWP 2905)]



evolution-shell-WARNING **: Error changing interactive status of component
OAFIID:GNOME_Evolution_Addressbook_ShellComponent to FALSE --
IDL:CORBA/COMM_FAILURE:1.0



Waiting for component to die -- OAFIID:GNOME_Evolution_Calendar_ShellComponent (1)

Waiting for component to die -- OAFIID:GNOME_Evolution_Mail_ShellComponent (1)



Program exited normally.

(gdb) bt

No stack.

(gdb) quit
Comment 1 Jeremy Katz 2002-08-29 01:01:34 EDT
The backtrace is completely non-useful.... I've added contacts here, so exactly
what did you do to reproduce?
Comment 2 louisgtwo 2002-08-29 21:26:43 EDT
This is one of those hit or miss bugs. I usually hit it while modifing some
addresses of contacts I already have. Is their a debug option I can run evo under?
Comment 3 Jeremy Katz 2002-08-29 23:02:13 EDT
Unfortunately not for the addressbook
Comment 4 Jeremy Katz 2003-02-09 21:50:26 EST
Closing due to lack of reproducability.  If you have a way to reproduce or a
backtrace with information, feel free to reopen this bug.
Comment 5 Kanwar Sandhu 2003-07-02 14:55:48 EDT
Evolution seg faults after about a minute after I open a contact and try editing
it.  Evolution itself keep running, but the contacts become unavailable.  The
only way to get them back is to shut down Evolution and restart it, which is
futile because as soon as I try editing a contact, the contact editor seg faults
again!  This has been occurring on a regular basis since I started to use
Evolution in RH 8.0 (currently I'm running RH 9).

Occasionally I can edit a contact without experiencing a seg fault, but that's
few and far between.

I don't how to do a backtrace, so if that's what you're looking for, I'll need
instructions on how to do it.

Note You need to log in before you can comment on or make changes to this bug.