Bug 726 - netmask 255.255.255.255 not allowed for host-route
netmask 255.255.255.255 not allowed for host-route
Status: CLOSED DUPLICATE of bug 1528
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-07 04:46 EST by juergen.klotz
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-01 15:41:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description juergen.klotz 1999-01-07 04:46:26 EST
when entering a host-route with netmask 255.255.255.255
route claims somthing like "netmask 00000000" not allowed
for host-route!

adding the host without specifying the netmask works pretty
well, but I want to use linuxconf to do this kinda stuff
and
    "linuxconf --hint routing eth1"
ouputs something like
    "add -host myhost gw mygate netmask 255.255.255.255".
Comment 1 juergen.klotz 1999-01-08 04:28:59 EST
I forgot, it's the Intel version
Comment 2 David Lawrence 1999-01-18 14:43:59 EST
Can you send some more details of your routing table.  I am unable to
replicate the problem in the test lab.
Comment 3 Preston Brown 1999-03-22 14:23:59 EST
Michael, have you ever seen anything like this?  If not, we haven't
seen any reponses from this individual in months, and we should close
the bug.
Comment 4 juergen.klotz 1999-03-24 05:01:59 EST
OOPS .....
I'm awefully sorry,
somehow your mail from 01/18/99 must have been dropped at my side!


This was the configuration when I postet the bug.
As you can see, I (unfortunately only) have three official addresses
and so I had to use a private one for the second interface on host B.

The machine the problem occured was host B.



+-----------------+       +----------------------------------+
+-----------------+
|        A        |       |                 B                |
|        C        |
| 193.174.  2. 12 |       | 193.174.  2.  8   10. 10. 10.  1 |       |
193.174.  2. 13 |
| 255.255.255.??? |       | 255.255.255.???  255.255.255.??? |       |
255.255.255.??? |
+-----------------+       +----------------------------------+
+-----------------+
         |                         |
|                       |
         + ------------------------+
+-----------------------+



At the moment, I do not remember the netmask as I'm currently only
running A and B and have no routing added for C.


The routing and interface configuration was done using linuxconf.
I've added an explicit host route to host C.
The output from linuxconf for the routing to C contained something
like "-host XXXXXX netmask 255.255.255.255" which was reject by
"route".


I'll try to figure out the old routing table and
interface configuration tomorrow if you want me to!




What I did to solve the problem at my side was to hack the code
of "route" to ignore the netmask for a explicit host routing.

Anyhow, I'm not shure if hacking code the way I did was a good
thing to do, but at least it solved my problem.

Anything was running quite well and so I forgot about the bug!
( ... hmmmmm, I think I remember ping complaining about having
 two interfaces for the route to C but it still worked!)
Comment 5 juergen.klotz 1999-03-24 05:08:59 EST
+-----------------+
|        A        |
| 193.174.  2. 12 |----+
| 255.255.255.??? |    |
+-----------------+    |
                       |
                       |
+-----------------+    |
|        C        |    |
| 193.174.  2.  8 |----+
| 255.255.255.??? |
|                 |
|  10. 10. 10.  1 |----+
| 255.255.255.??? |    |
+-----------------+    |
                       |
                       |
+-----------------+    |
|        C        |    |
| 193.174.  2. 13 |----+
| 255.255.255.??? |
+-----------------+
Comment 6 juergen.klotz 1999-03-24 07:48:59 EST
+-----------------+
|        A        |
| 193.174.  2. 12 |----+
| 255.255.255.??? |    |
+-----------------+    |
                       |
                       |
+-----------------+    |
|        C        |    |
| 193.174.  2.  8 |----+
| 255.255.255.??? |
|                 |
|  10. 10. 10.  1 |----+
| 255.255.255.??? |    |
+-----------------+    |
                       |
                       |
+-----------------+    |
|        C        |    |
| 193.174.  2. 13 |----+
| 255.255.255.??? |
+-----------------+
Comment 7 Michael K. Johnson 1999-04-01 15:41:59 EST
I've marked this bug as a duplicate of bug 1528, which says that
it is about the 2.2 kernel, but is really about a certain rev of
route.

*** This bug has been marked as a duplicate of 1528 ***

Note You need to log in before you can comment on or make changes to this bug.