Bug 726029 - [abrt] smolt-1.4.3-4.fc16 + kernel-3.x: smolt.py:283:__init__:TypeError: 'NoneType' object is not subscriptable
[abrt] smolt-1.4.3-4.fc16 + kernel-3.x: smolt.py:283:__init__:TypeError: 'Non...
Status: CLOSED DUPLICATE of bug 722859
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
abrt_hash:c3beafe56581ad74460b5572fd1...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-27 07:14 EDT by Nicolas Mailhot
Modified: 2011-08-25 16:25 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-25 16:25:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2011-07-27 07:14:35 EDT
abrt version: 2.0.5
cmdline:        /usr/bin/python /usr/bin/smoltSendProfile -p
comment:        While smolt was called by abrt to diagnose another problem
executable:     /usr/bin/smoltSendProfile
kernel:         3.0.0-1.fc16.x86_64
reason:         smolt.py:283:__init__:TypeError: 'NoneType' object is not subscriptable
time:           Wed Jul 27 13:08:54 2011
uid:            500
username:       nim

backtrace:
:smolt.py:283:__init__:TypeError: 'NoneType' object is not subscriptable
:
:Traceback (most recent call last):
:  File "/usr/bin/smoltSendProfile", line 152, in <module>
:    profile = smolt.get_profile()
:  File "/usr/share/smolt/client/smolt.py", line 1415, in get_profile
:    return Hardware()
:  File "/usr/share/smolt/client/smolt.py", line 1004, in Hardware
:    _hardware_instance = _Hardware()
:  File "/usr/share/smolt/client/smolt.py", line 591, in __init__
:    self.host = Host()
:  File "/usr/share/smolt/client/smolt.py", line 283, in __init__
:    self.systemMemory = Gate().process('ram_size', memory['ram'], 0)
:TypeError: 'NoneType' object is not subscriptable
:
:Local variables in innermost frame:
:cpuInfo: {'count': 2, 'model_ver': '23', 'cpu_stepping': '10', 'speed': 2834, 'cache': '6144 KB', 'model_number': '6', 'bogomips': '6332.28', 'cpu_model_num': '23', 'platform': 'x86_64', 'other': 'fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dts tpr_shadow vnmi flexpriority', 'cpu_family': '6', 'model': 'Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz', 'type': 'GenuineIntel', 'class': 'CPU', 'desc': 'Processor'}
:self: <smolt.Host instance at 0x387acf8>
:memory: None

smolt_data:
:Traceback (most recent call last):
:  File "/usr/bin/smoltSendProfile", line 152, in <module>
:    profile = smolt.get_profile()
:  File "/usr/share/smolt/client/smolt.py", line 1415, in get_profile
:    return Hardware()
:  File "/usr/share/smolt/client/smolt.py", line 1004, in Hardware
:    _hardware_instance = _Hardware()
:  File "/usr/share/smolt/client/smolt.py", line 591, in __init__
:    self.host = Host()
:  File "/usr/share/smolt/client/smolt.py", line 283, in __init__
:    self.systemMemory = Gate().process('ram_size', memory['ram'], 0)
:TypeError: 'NoneType' object is not subscriptable
Comment 1 Nicolas Mailhot 2011-07-27 07:14:44 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 17 (Rawhide)

Comment
-----
While smolt was called by abrt to diagnose another problem
Comment 2 Nicolas Mailhot 2011-07-30 04:38:55 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 17 (Rawhide)

Comment
-----
while running an abrt report
Comment 3 Nicolas Mailhot 2011-07-30 04:39:04 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 17 (Rawhide)

Comment
-----
while running an abrt report
Comment 4 Nicolas Mailhot 2011-08-01 13:50:10 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 17 (Rawhide)

Comment
-----
invoqued from abrt
Comment 5 Tim Flink 2011-08-05 16:47:24 EDT
Package: smolt-1.4.3-4.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Tried to generate smolt profile inside ABRT
Comment 6 Jens Petersen 2011-08-12 04:34:35 EDT
Package: smolt-1.4.3-4.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
when gathering smolt info for abrt report
Comment 7 Mads Kiilerich 2011-08-12 12:57:38 EDT
Proposed patch:

--- /usr/share/smolt/client/smolt.py	2011-01-11 15:25:19.000000000 +0000
+++ smolt.py	2011-08-12 16:37:45.632425601 +0000
@@ -1347,10 +1347,9 @@
 def read_memory():
     un = os.uname()
     kernel = un[2]
-    if kernel[:3] == "2.6":
-        return read_memory_2_6()
     if kernel[:3] == "2.4":
         return read_memory_2_4()
+    return read_memory_2_6()
 
 def read_memory_2_4():
     if not os.access("/proc/meminfo", os.R_OK):

I assume that a consequence of this bug is that all f16 testing reports will have sub-optimal bug reports. A fix would IMHO be NTH.
Comment 8 Tim Flink 2011-08-12 14:56:45 EDT
Discussed in the 2011-08-12 blocker review meeting. While it would be nice to have smolt working for alpha, there is a possibility of impacting firstboot and we decided that the risk outweighed the benefit. Rejected as NTH for Fedora 16.

The fix can be pulled in post-alpha without NTH.
Comment 9 Matthias Runge 2011-08-17 08:01:05 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
run smoltSendProfile
Comment 10 Robert Lightfoot 2011-08-18 08:31:31 EDT
Package: smolt-1.4.3-4.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
ssh conection running fedora-easy-karma
vnc connection running firefox to bugzilla
search for bug after login
get crash
attempt to report crsh with abrt
durin smolt phas get this crash
Comment 11 DiEOrLivE 2011-08-21 13:08:09 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
when reporting a bug
Comment 12 DiEOrLivE 2011-08-21 13:09:39 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
i dont know
Comment 13 kksheth 2011-08-25 03:43:04 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
no comment
Comment 14 Patsev Anton 2011-08-25 04:16:29 EDT
Package: smolt-1.4.3-4.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
install fedora 16 alpha
Comment 15 Clément DAVID 2011-08-25 08:10:35 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I got an error the first time using smolt (it has not been started on post-install). I launched it through the ABRT UI and the error pop-ed up.
Comment 16 Orion Poplawski 2011-08-25 16:25:09 EDT

*** This bug has been marked as a duplicate of bug 722859 ***

Note You need to log in before you can comment on or make changes to this bug.