Bug 72613 - Can't load X server when using an nForce MB
Can't load X server when using an nForce MB
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 00:30 EDT by Ryan
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 15:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan 2002-08-26 00:30:55 EDT
Description of Problem:  I can't install Rawhide using the graphical 
installer.  It says trying to load X and counts to 5 then a black screen is as 
far as it goes. 
 
 
How Reproducible: Easy. 
 
 
Steps to Reproduce: 
 
Get a computer that has an MSI nForce motherboard in it.  Try and install 
Rawhide on it using the graphical installer while booting off the CD.  
 
 
Actual Results: A black screen. 
 
 
Expected Results: Actually installing the OS. 
 
 
Additional Information:  Please include the nForce drivers and the Nvidia card 
drivers with the next beta and future releases. 
 
GeForce card drivers: 
 
http://nvidia.com/view.asp?PAGE=linux  
 
nForce drivers: 
 
http://nvidia.com/view.asp?IO=linux_nforce_1.0-0241  
 
I want to see those drivers, or newer ones in the ISO.
Comment 1 Mike A. Harris 2002-08-26 15:16:03 EDT
You will not see those drivers on the ISO, or anywhere in Red Hat Linux.
Red Hat does not support proprietary closed source drivers, and currently
has no intention of doing so in the future.  Red Hat does not include
binary only driver code in the distribution because it is not maintainable
nor supportable.

In order to get this hardware to function under Red Hat Linux, users need
to acquire the drivers themselves from Nvidia, and also seek any and all
technical support from Nvidia while using these drivers.

We only support the open source "nv" driver, and using that driver, we
only support the hardware which it contains support for.  That list
of hardware is available from:

http://www.xfree86.org/4.2.0/Status.html

If a piece of hardware is not explicitly on that list, then it is not
officially supported by XFree86, nor by Red Hat.  Users may try using
the "vesa" driver for a mediocre 2D driver, however we merely provide
that driver and do not officially support it either since generally
bugs that occur using the "vesa" driver are bugs in the video cards
own BIOS, and we're unable to fix BIOS bugs.
Comment 2 Mike A. Harris 2002-08-26 15:20:30 EDT
As an added note, the Nvidia drivers contain binary-only code compiled
with gcc 2.x.  Kernels compiled with gcc 3.x can not safely load code
compiled with gcc 2.x without risk of data loss.

Current Red Hat Linux beta releases and rawhide contain kernels compiled
with gcc 3.2.  Mandrake's beta release also contains gcc 3.2, and most
likely all other major distributions will be using gcc 3.2 ASAP also.

In order for the Nvidia drivers to work, Nvidia will need to release
new gcc 3.2 compiled binaries.

Note You need to log in before you can comment on or make changes to this bug.