Bug 72616 - Mozilla fails to respect system DPI settings.
Mozilla fails to respect system DPI settings.
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
null
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 01:24 EDT by Shane R. Stixrud
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 01:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane R. Stixrud 2002-08-26 01:24:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:

The default Mozilla font settings do not seem to work as intended. 
RedHat's Display settings under monitor reports that I am using 96DPI fonts.  
Yet when mozilla is set to use "System Settings" for DPI some fonts are very 
very small and unreadable.  This can be witnessed on 
RedHat's website www.redhat.com, the copy-write notice at the bottom of the 
page is unreadable.  Setting Mozilla to 96DPI solves this problem.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open mozilla
2.Go to www.redhat.com
3.look at font at the bottom of the page (copywrite notice)
4. Change Mozilla's DPI font settings from "Use system" to 96DPI.  repeat 
steps 1-3.
	

Actual Results:  The correct fonts are not used.

Expected Results:  96DPI fonts to be used.

Additional info:
Comment 1 Christopher Blizzard 2002-08-30 11:02:58 EDT
Mozilla is using the xfree DPI.  The setting is for fontconfig/xft iirc.  Once
we start using Mozilla w/ fontconfig/xft this will be fixed.

Note You need to log in before you can comment on or make changes to this bug.