Bug 726167 - Error polling connection 'qemu:///system': internal error Cannot find suitable emulator for x86_64
Summary: Error polling connection 'qemu:///system': internal error Cannot find suitabl...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-virtinst
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-27 17:52 UTC by darrell pfeifer
Modified: 2012-01-24 08:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-01 20:58:16 UTC


Attachments (Terms of Use)

Description darrell pfeifer 2011-07-27 17:52:25 UTC
Description of problem:

Error polling connection 'qemu:///system': internal error Cannot find suitable emulator for x86_64


Version-Release number of selected component (if applicable):

virt-manager-0.9.0-3.fc17


How reproducible:

Start virt-manager on an x86 system


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Error polling connection 'qemu:///system': internal error Cannot find suitable emulator for x86_64

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 440, in _tick
    conn.tick()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1414, in tick
    newNets, self.nets) = self._update_nets()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1277, in _update_nets
    lookup_func, build_class)
  File "/usr/share/virt-manager/virtManager/connection.py", line 1209, in _poll_helper
    if not check_support():
  File "/usr/share/virt-manager/virtManager/connection.py", line 501, in is_network_capable
    virtinst.support.SUPPORT_CONN_NETWORK)
  File "/usr/lib/python2.7/site-packages/virtinst/support.py", line 574, in check_conn_support
    return _check_support(conn, feature, conn)
  File "/usr/lib/python2.7/site-packages/virtinst/support.py", line 443, in _check_support
    actual_drv_ver = _hv_ver(conn, uri)
  File "/usr/lib/python2.7/site-packages/virtinst/support.py", line 376, in _hv_ver
    ret = cmd(*args)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 2520, in getVersion
    if ret == -1: raise libvirtError ('virConnectGetVersion() failed', conn=self)
libvirtError: internal error Cannot find suitable emulator for x86_64


Expected results:


Additional info:

yum list qemu\*
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
qemu-common.x86_64                                 2:0.15.0-0.2.20110718525e3df.fc16                             @koji/16
qemu-img.x86_64                                    2:0.15.0-0.2.20110718525e3df.fc16                             @koji/16
qemu-kvm.x86_64                                    2:0.15.0-0.2.20110718525e3df.fc16                             @koji/16
qemu-system-x86.x86_64                             2:0.15.0-0.2.20110718525e3df.fc16                             @koji/16
Available Packages
qemu.i686                                          2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu.x86_64                                        2:0.15.0-0.2.20110718525e3df.fc16                             koji    
qemu-common.i686                                   2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-img.i686                                      2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-kvm.i686                                      2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-kvm-tools.i686                                2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-kvm-tools.x86_64                              2:0.15.0-0.2.20110718525e3df.fc16                             koji    
qemu-launcher.noarch                               1.7.4-7.fc12                                                  koji    
qemu-system-arm.i686                               2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-system-arm.x86_64                             2:0.15.0-0.2.20110718525e3df.fc16                             koji    
qemu-system-cris.i686                              2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-system-cris.x86_64                            2:0.15.0-0.2.20110718525e3df.fc16                             koji    
qemu-system-m68k.i686                              2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-system-m68k.x86_64                            2:0.15.0-0.2.20110718525e3df.fc16                             koji    
qemu-system-mips.i686                              2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-system-mips.x86_64                            2:0.15.0-0.2.20110718525e3df.fc16                             koji    
qemu-system-sh4.i686                               2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-system-sh4.x86_64                             2:0.15.0-0.2.20110718525e3df.fc16                             koji    
qemu-system-x86.i686                               2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-user.i686                                     2:0.15.0-0.2.20110718525e3df.fc16                             koji32  
qemu-user.x86_64                                   2:0.15.0-0.2.20110718525e3df.fc16                             koji

Comment 1 darrell pfeifer 2011-07-27 18:14:07 UTC
Also installed qemu-x86_64 but the error remains.

yum list qemu\*
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
qemu.x86_64                                        2:0.15.0-0.2.20110718525e3df.fc16                             @koji   
qemu-common.x86_64                                 2:0.15.0-0.2.20110718525e3df.fc16                             @koji/16
qemu-img.x86_64                                    2:0.15.0-0.2.20110718525e3df.fc16                             @koji/16
qemu-kvm.x86_64                                    2:0.15.0-0.2.20110718525e3df.fc16                             @koji/16
qemu-system-arm.x86_64                             2:0.15.0-0.2.20110718525e3df.fc16                             @koji   
qemu-system-cris.x86_64                            2:0.15.0-0.2.20110718525e3df.fc16                             @koji   
qemu-system-m68k.x86_64                            2:0.15.0-0.2.20110718525e3df.fc16                             @koji   
qemu-system-mips.x86_64                            2:0.15.0-0.2.20110718525e3df.fc16                             @koji   
qemu-system-sh4.x86_64                             2:0.15.0-0.2.20110718525e3df.fc16                             @koji   
qemu-system-x86.x86_64                             2:0.15.0-0.2.20110718525e3df.fc16                             @koji/16
qemu-user.x86_64                                   2:0.15.0-0.2.20110718525e3df.fc16                             @koji

Comment 2 Cole Robinson 2011-08-01 20:58:16 UTC
The root cause is this qemu bug:

https://bugzilla.redhat.com/show_bug.cgi?id=724814

However I've pushed an updated python-virtinst build that will at least catch this error so that you can 'open' the connection and have a better chance of finding out what's wrong (the new VM wizard will give some more info)

But basically until that above bug is fixed you can't do a whole lot with the connection.

Comment 3 Eduardo Mejia 2012-01-18 15:14:38 UTC
I just installed RHEL

# uname -arn
Linux bunker.localdomain 2.6.32-220.2.1.el6.x86_64 #1 SMP Tue Dec 13 16:21:34 EST 2011 x86_64 x86_64 x86_64 GNU/Linux


I'm getting the following message

Error polling connection 'qemu:///system': internal error Cannot find suitable emulator for x86_64

The detailed information is the following


Error polling connection 'qemu:///system': internal error Cannot find suitable emulator for x86_64

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 440, in _tick
    conn.tick()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1414, in tick
    newNets, self.nets) = self._update_nets()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1277, in _update_nets
    lookup_func, build_class)
  File "/usr/share/virt-manager/virtManager/connection.py", line 1209, in _poll_helper
    if not check_support():
  File "/usr/share/virt-manager/virtManager/connection.py", line 501, in is_network_capable
    virtinst.support.SUPPORT_CONN_NETWORK)
  File "/usr/lib/python2.6/site-packages/virtinst/support.py", line 574, in check_conn_support
    return _check_support(conn, feature, conn)
  File "/usr/lib/python2.6/site-packages/virtinst/support.py", line 443, in _check_support
    actual_drv_ver = _hv_ver(conn, uri)
  File "/usr/lib/python2.6/site-packages/virtinst/support.py", line 376, in _hv_ver
    ret = cmd(*args)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2823, in getVersion
    if ret == -1: raise libvirtError ('virConnectGetVersion() failed', conn=self)
libvirtError: internal error Cannot find suitable emulator for x86_64


Yesterday, RHN adviced me for libvirt updates, I updated it but the problem still driving me crazy

I don't know what to do, even when I run as root 
#virt-manager --debug I get this message

 if ret == -1: raise libvirtError ('virConnectGetVersion() failed', conn=self)
libvirt.libvirtError: internal error Cannot find suitable emulator for x86_64
2012-01-18 10:14:17,028 (error:80): dialog message: Error polling connection 'qemu:///system': internal error Cannot find suitable emulator for x86_64 : Error polling connection 'qemu:///system': internal error Cannot find suitable emulator for x86_64


I will appreciate your help.


Best Regards.

Comment 4 Atro Tossavainen 2012-01-24 08:51:07 UTC
It may not be a software problem at all. As per http://barryp.org/blog/entries/make-sure-virtualization-enabled-bios/, make sure virtualization is enabled in the BIOS. I had this problem on a new system and it went away when I did.


Note You need to log in before you can comment on or make changes to this bug.