Bug 726178 - (EAP 5.1.x admin-console) [RFE] [UI] The result of invoking an operation can be misleading or confused with the actual result of the operation
(EAP 5.1.x admin-console) [RFE] [UI] The result of invoking an operation can ...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
unspecified
All All
medium Severity high (vote)
: ---
: ---
Assigned To: Jan Martiska
Mike Foley
:
Depends On:
Blocks: 725869
  Show dependency treegraph
 
Reported: 2011-07-27 14:31 EDT by Ian Springer
Modified: 2013-08-05 20:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 710230
Environment:
EAP_EWP 5.1.0 - admin-console
Last Closed: 2012-02-07 14:29:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
actual EAP 5.1.2 ER1 console (108.83 KB, image/png)
2011-10-12 08:08 EDT, Jan Martiska
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-7412 None Closed [Bug 726178] The result of invoking an operation can be misleading or confused with the actual result of the operation 2012-02-17 07:44:24 EST

  None (edit)
Description Ian Springer 2011-07-27 14:31:00 EDT
+++ This bug was initially created as a clone of Bug #710230 +++

Created attachment 502598 [details]
Screen shot of admin-console showing confusion when invoking the Test Connection operation on a datasource

In some cases, the result of invoking an operation can be confused with the result of the actual operation. 

For example:

For a datasource resource, you can invoke the "Test Connection" operation. Once the operation has been submitted, the "Operation History" will indicate "Successful". This "Successful" message can easily be interrupted as the connection to the datasource was successful when in reality, the actual test of the datasource connection returned failed. 

This is confusing to operational admins looking at this UI to test a connection. In fact, this would mislead them to look at the wrong section and proceed thinking the connection has been obtained when it's not, and could possibly cause serious production ramifications. The UI should be re-worked and be more intuitive and clear.
Comment 1 Ian Springer 2011-07-27 14:33:04 EDT
Fixed in AdminConsole_EAP_5_1 branch (commit 12148f7) - improved the description of the 'testConnection' datasource/connFactory operation so it makes it clear that the operation always returns SUCCESS even if the connection test failed.

The fix still needs to be committed to master.
Comment 2 Mike Foley 2011-07-29 15:16:57 EDT
discussed with ips:  verification is to be performed by EAP QA
Comment 3 Jan Martiska 2011-10-07 11:18:18 EDT
wasn't this fix meant to be applied to EAP admin-console? Yes, the fix is present in the descriptor of EAP5-plugin for RHQ (commit 12148f7), but from the name of this issue and also the screenshot, I thought the same change was meant to be done for EAP admin console, which it seems hasn't been done. At least in EAP 5.1.2 ER1 admin console, the description of "Test Connection" operation is still the same, the confusing one, so I really don't understand why this is already ON_QA. If I am missing something, please correct me.
Comment 4 Larry O'Leary 2011-10-07 11:56:38 EDT
Yes. The fix can be seen in the tag for EAP 5.1.2 ER1 admin-console - http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=blob;f=modules/plugins/jboss-as-5/src/main/resources/META-INF/rhq-plugin.xml;h=71cfccec533ba0b5c25a4b9ac924ebc24b6f859d;hb=0cf4f6b696f31e115165b826af14570a6b8a0b20 

So if it isn't there then EAP has some build issue because https://issues.jboss.org/browse/JBPAPP-6766 indicates that the component upgrade was complete.for ER1.
Comment 5 Jan Martiska 2011-10-12 08:08:22 EDT
Created attachment 527684 [details]
actual EAP 5.1.2 ER1 console

I attached a screenshot proving that in EAP 5.1.2 ER1 this is not fixed. The EMBJOPR version (in the bottom of the screen) correctly says 1.3.4.SP5, but the description is not changed. Can someone investigate why this happens?
Comment 10 Jan Martiska 2011-11-10 04:09:03 EST
Verified with EAP/EWP 5.1.2 ER2.
Comment 11 Mike Foley 2012-02-07 14:29:14 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE
Comment 12 Mike Foley 2012-02-07 14:30:06 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.