Bug 726235 - German umlauts are not working if opponent uses Pidgin
Summary: German umlauts are not working if opponent uses Pidgin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: licq
Version: 16
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: François Cami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-27 22:05 UTC by Marc Muehlfeld
Modified: 2012-07-10 20:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-10 20:57:27 UTC
Type: ---


Attachments (Terms of Use)

Description Marc Muehlfeld 2011-07-27 22:05:06 UTC
Description of problem:
If I run Licq on my computer and my opponent uses Pidgin, german umlauts making trouble. I tried all suitable encodings in Licq. With some I see the umlauts, with others my opponent see them. But with non encoding both are seeing umlauts.


Version-Release number of selected component (if applicable):
Licq 1.3.5-10.fc15
Licq-KDE 1.3.5-10.fc15


How reproducible:
Always.


Steps to Reproduce:
- Start an ICQ conversation with somebody who uses Pidgin (regardless Win/Linux).
- Set encoding on my side to CP1252 (the default encoding Windows Pidgin uses): If I type umlauts, I and my oppenent see them. But if my opponent types some, I receive "äöü" instaed of "äöü".
- Set encoding on my side to UTF8 (System default): I can see umlauts I've typed and I can receive umlauts. But my opponent sees "äöü" instead of "äöü" if I send them.

  
Actual results:
It's not possible that sender and receiver see umlauts at the same time. Regardless which encoding was choosen in Licq, just one can see them.


Expected results:
Umlauts should be visible for both sides.


Additional info:
I had this problem only if the opponent uses Pidgin. If he/she uses other clients (e.g. the icq2go Webclient) umlauts work on both sides.

Also there is no problem if I use a differnt client (like SIM-IM or icq2go Webclient) for a conversation with Pidgin users.

I tried conversations with oponents using different versions of Pidgin: 2.9.0 (26.04.2011), 2.8.0 (08.06.2011),... The umlaut problem exists regardless which version the opponent uses.

Comment 1 Marc Muehlfeld 2011-08-01 18:20:18 UTC
Just a note: I meanwhile compiled the latest version 1.5.1 by myself. This version is working fine and doesn't have this issue when chatting with pidgin users. So the bug seems to be in the Licq  package included in F15 or Licq 1.3.5 itself.

Comment 2 Akira TAGOH 2012-06-28 13:13:27 UTC
I'm not an user of licq - just built licq-1.6.1-1.fc18 in rawhide as provenpackager. there seems a lot of changes in upstream. so please check if it still works for you. once it's confirmed, will push as updates then. thanks.

Comment 3 Marc Muehlfeld 2012-06-28 15:20:11 UTC
Sorry, but I don't know how to create RPM packages. I only know how to compile the application for my own system.

Comment 4 Fedora Update System 2012-06-29 08:29:02 UTC
licq-1.6.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/licq-1.6.1-1.fc17

Comment 5 Fedora Update System 2012-06-29 08:54:15 UTC
licq-1.6.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/licq-1.6.1-1.fc16

Comment 6 Marc Muehlfeld 2012-06-29 19:58:08 UTC
I checked the rpm for f17 on i686. Looks good and german umlauts are working with pidgin opponent.

Thanks.

Comment 7 Fedora Update System 2012-06-30 22:02:17 UTC
Package licq-1.6.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing licq-1.6.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10086/licq-1.6.1-1.fc17
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-07-10 20:57:27 UTC
licq-1.6.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2012-07-10 20:57:55 UTC
licq-1.6.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.