Bug 72632 - Exits with segmentation fault
Summary: Exits with segmentation fault
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: skkinput   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-26 06:28 UTC by yamagata
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-03 02:56:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "strace skkinput &>skkinput.starce" with "XIM=skkinput startx" (24.26 KB, text/plain)
2002-09-02 01:03 UTC, yamagata
no flags Details

Description yamagata 2002-08-26 06:28:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
Skkinput cannot run and exits with "Segmentation fault"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run "startx" on a virtual console.
2.Skkinput has not been started.
3.Type "skkinput" on a kterm.
	

Actual Results:  I see "Segmentation fault" in Japanese.

Additional info:

When X is started, evironment variables, LANG, XIM_PROGRAM, and XMODIFIERS are
set to ja_JP.eucJP, skkinput, and @im=skkinput, respectively, with
/etc/X11/xinit/xinitrc.d/xinput.

kinput2 runs well.

The installed packages are as follows: kernel-2.4.18-10, glibc-2.2.5-39,
XFree86-4.2.0-8, XFree86-S3-3.3.6-44, skkinput-2.03-9, kterm-6.2.0-28, and so on.

Comment 1 Jens Petersen 2002-08-30 08:13:55 UTC
Thank you for the report.

I think I need more information on how to reproduce your problem.
For me on a 7.3 machine if I start up X with "XIM=skkinput startx"
for example, skkinput works for me ok.

Btw have you enabled dbskkd-cdb in xinetd?

# chkconfig dbskkd-cdb on


Comment 2 yamagata 2002-08-30 09:46:50 UTC
Skkinput dose not work if I start up X with "XIM=skkinput startx".

I have enabled dbskkd-cdb in xinetd. I have checked the connection estabilshed
with "telnet localhost 1178".

Comment 3 Jens Petersen 2002-08-30 10:27:35 UTC
So with "XIM=skkinput startx", skkinput still segfaults for you?

Can you try to run skkinput through strace ("strace skkinput")
and attach the output?  Perhaps that will give a better idea of
what the problem could be.

Comment 4 yamagata 2002-09-02 01:01:09 UTC
I atach the output of "strace skkinput &>skkinput.strace" with "XIM=skkinput
startx".

Comment 5 yamagata 2002-09-02 01:03:06 UTC
Created attachment 74445 [details]
Output of "strace skkinput &>skkinput.starce" with "XIM=skkinput startx"

Comment 6 Jens Petersen 2002-09-02 09:59:25 UTC
Hmmm, there are some differences between your strace output and mine, but
it doesn't really give any clues about why your skkinput is segfaulting.

Anyway could you please try running skkinput in a new user account,
ie without any local configurations.  (I see from the trace you have
various Xdefaults being read in.)  Also it shouldn't really matter much,
but I am using gnome-terminal by default.

If that doesn't work either, I am kind of at a loss at how to help further,
since I can reproduce your problem here are all.  Perhaps you could also
try to do a fresh install of 7.3 + updates on a test machine to see if
you can reproduce the problem there yourself.  I can't say for sure, but
it seems likely the problem is caused by some local configuration on your
machine perhaps?

Comment 7 yamagata 2002-09-03 02:01:22 UTC
Skkinput works fine in a new user account on both GNOME and TWM. Hence it seems
to cause this problem by some my configuration. I try to find them. Thank you
for your helpful advice.

Comment 8 yamagata 2002-09-03 02:55:54 UTC
I have found the file, ~/.skkinput-jisyo-autosave, causes this problem. It must
be corrupted. When it is deleted, skkpinut works well and a new file,
~/.skkinput-jisho-autosave, is created.

Comment 9 Jens Petersen 2002-09-03 05:56:15 UTC
Ok, thanks, that is good to hear.  I wonder how the file got corrupted.
Closing this for now.


Note You need to log in before you can comment on or make changes to this bug.