Bug 726385 - too few arguments for format in a debugging string
too few arguments for format in a debugging string
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: foomatic (Show other bugs)
6.2
Unspecified Unspecified
low Severity unspecified
: rc
: ---
Assigned To: Tim Waugh
Desktop QE
:
Depends On: 726384
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 09:14 EDT by Tomas Pelka
Modified: 2013-07-18 19:43 EDT (History)
5 users (show)

See Also:
Fixed In Version: foomatic-4.0.4-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: A programming error meant that there were not enough arguments for a formatting string when logging debugging information. Consequence: In certain circumstances, print jobs requiring the foomatic-rip filter were printed as raw text without filtering. Fix: The programming error has been corrected. Result: The foomatic-rip filter now behaves as expected.
Story Points: ---
Clone Of: 726384
Environment:
Last Closed: 2013-07-17 05:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foomatic.bt (11.83 KB, text/plain)
2011-07-28 09:14 EDT, Tomas Pelka
no flags Details

  None (edit)
Description Tomas Pelka 2011-07-28 09:14:46 EDT
Created attachment 515719 [details]
foomatic.bt

+++ This bug was initially created as a clone of Bug #726384 +++

Description of problem:
Too few arguments for format in a debugging string in foomatic-rip.c:1644.

Version-Release number of selected component (if applicable):
foomatic-4.0.7-2.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1.foomatic-rip -v --ppd /dev/null /dev/null
  
Actual results:
Raw printing, executing "cat "

Expected results:
Don't have undefined characters in output.

Additional info:
Just missing the value for "%s".
Comment 2 Suzanne Yeghiayan 2012-02-14 18:11:50 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 errata-xmlrpc 2013-07-17 05:26:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1084.html

Note You need to log in before you can comment on or make changes to this bug.