This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 726558 - Zanata deployment issue in RHEL6
Zanata deployment issue in RHEL6
Status: CLOSED NEXTRELEASE
Product: Zanata
Classification: Community
Component: Deployment (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 21:45 EDT by Michelle Kim
Modified: 2011-09-11 20:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-25 23:21:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michelle Kim 2011-07-28 21:45:44 EDT
Description of problem:

L10n team is in the process of upgrading CSB5 to CSB6 (RHEL5 -> RHEL6) and found out that zanata does not work in CSB6 due to an error of the package python-httplib2

Also maven package is not included in EPEL.

Actual results:

error: Error happens when processing https
If version of python-httplib2 < 0.4.0, please use the patch in http://code.google.com/p/httplib2/issues/detail?id=39

# yum list maven*
Error: No matching Packages to list

Expected results:

Working Zanata without throwing out any error messages in RHEL6 and include maven for epel.
Comment 1 Sean Flanigan 2011-07-28 22:00:12 EDT
We'll have to get the hotfix patch for httplib2 applied in EPEL6.  We'll probably need help from a provenpackager.  

Otherwise we might be able to modify zanata-python-client so that it no longer uses httplib2 (not sure if that's practical).
Comment 2 Manuel Ospina 2011-07-28 22:50:29 EDT
The package in EPEL6 is pretty old: version 0.4.0. The version in Fedora 14 is 0.6.0. I sent an email to epel-devel-list asking to have the package updated, but I haven't got any reply yet.
Comment 3 Sean Flanigan 2011-07-29 03:10:27 EDT
Regarding maven:

For F14/F15: 'yum install maven2' should work.
For RHEL6: use this repo: http://repos.fedorapeople.org/repos/dchen/apache-maven/epel-apache-maven.repo and then 'yum install apache-maven'

The above packages provide the executable 'mvn' which can invoke zanata-maven-plugin.
Comment 4 Ding-Yi Chen 2011-08-25 23:21:53 EDT
python-httplib2-0.4.0-5.el6, which contains the fix, is pushed to stable.

Note You need to log in before you can comment on or make changes to this bug.