This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 72663 - Gnome panel desktop switcher stops working after sawfish workspaces are changed
Gnome panel desktop switcher stops working after sawfish workspaces are changed
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
: MoveUpstream, Triaged
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-26 10:07 EDT by Ted Clark
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 23:43:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ted Clark 2002-08-26 10:07:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
The Gnome panel desktop switcher stops working after sawfish workspaces are
changed.  This only happens with sawfish; it does not happen with metacity.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Add a workspace from the sawfish Customize -> Workspaces menu.
2. Try to switch workspaces from the Gnome panel workspace switcher.
3.
	

Actual Results:  The Gnome panel workspace switcher stops working; it will not
switch to another workspace.

Expected Results:  The Gnome panel workspace switcher should continue to work
after sawfish workspaces are changed.

Additional info:
Comment 1 Ted Clark 2002-08-28 09:05:53 EDT
I noticed that when I add/delete a workspace from Sawfish -> Customize ->
Workspaces that sometimes the Gnome panel workspace switcher reverts to 1
workspace.  This causes the Gnome panel workspacer switcher to appear not to
work, since the switcher defaults (or gets reset?) to 2 rows and the other
workspace is "dead."  Resetting the proper number of workspaces in Gnome Panel
-> Preferences fixes this.
Comment 2 Ted Clark 2002-08-28 13:03:42 EDT
Ok, it appears that the problem is that Gnome panel resets the number of
workspaces to 1 every time sawfish is started.  This includes logging out and
back in.  I have tried reseting the number of sessions and running
gnome-session-save, but this doesn't work.
Comment 3 Ted Clark 2002-08-28 13:05:37 EDT
Sorry, s/sessions/workspaces/ above.
Comment 4 Joseph R. Kiniry 2002-12-03 05:59:53 EST
I am also experiencing this bug using the workspace manager and sawfish.

Additionally, there seems to be no way to use viewports in lieu of workspaces
anymore.  The workspace switcher does not recognize multiple viewports as a
legitimate option.
Comment 5 Havoc Pennington 2002-12-03 12:52:40 EST
Sawfish doesn't have viewports anymore, as far as I know.

This bug needs filing on bugzilla.gnome.org, if it hasn't already been.
We really provide Sawfish on an "as is" basis in 8.0 and later, we don't do
anything to it on the Red Hat level other than upgrade to latest version and fix
our own screwups (packaging errors etc.)

It's possible this is fixed in newer versions.
Comment 6 Felipe Alfaro Solana 2002-12-27 14:08:32 EST
Still, as of "sawfish-1.2-2" in Phoebe, every time you log on your GNOME
desktop, the number of workspaces is reset to 1. I must manually reconfigure
workspace manager to display 4 workspaces, but if I log on and then log off, the
number of configured workspaces is reset to 1.

Will this fixed? This has happened since Limbo betas! It seems Sawfish has been
replaced by Metacity and that Sawfish development and bug fixing has halted.
However, I find Sawfish far more powerful and useable than Metacity. Please,
keep Sawfish up to date!
Comment 7 Havoc Pennington 2003-01-12 23:43:07 EST
Reported as: http://bugzilla.gnome.org/show_bug.cgi?id=103346

Closing on Red Hat level.

Note You need to log in before you can comment on or make changes to this bug.