This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 726651 - Brightness not changeable after suspend/hibernate on HP 8530w tag
Brightness not changeable after suspend/hibernate on HP 8530w tag
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
backlight suspend hibernate first=2.6...
: Reopened
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2011-07-29 06:53 EDT by Lari Tanase
Modified: 2013-01-02 08:11 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 08:11:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lari Tanase 2011-07-29 06:53:12 EDT
Description of problem:

Hardware - Laptop HP EliteBook 8530w clean install F15 and update to 20110729 

the backlight apparently works ok
(even the "auto light sensor icon seems to look exactly the same as touchpad)

but after forced to hibernating or forced to suspend (or wait until power manager sent to any of this states) brightness of display is around 25% and controls don't work at all
(FN + F9/F10/F11)
also autodim sensor seems to don't work

tried to force with 
pkexec gnome-power-backlight-helper --set-brightness 1~24 
- no visual improvements 
- values over 25 gives the error 
       " Could not set the value of backlight: writting '25' to /sys/class/backlight/acpi_video0/brightness failed"



Version-Release number of selected component (if applicable):
FC 15 Linux 2.6.38.8-35.fc15.x86_64
gnome-power-manager version 3.0.0.-3.fc15


How reproducible:
each time laptop enter in one of suspend or hibernate state

Steps to Reproduce:
1. boot 
2. wait until any state (suspend / hibernate) occur or force suspend or hibenrate
3. push power button 

  
Actual results:
diplay brightness is les than half and no way to control it via any buttons commands

Expected results:
display should remain at the previous state + user should have control via built in buttons (FN + F9,10,11)


Additional info:
Comment 1 Lari Tanase 2011-07-29 08:34:00 EDT
It does the same bad behavior if I close the lid of my laptop

even after the boot

reboot computer - everything seems ok
login screen appear - but instead to log in I close the lid and the open it back 
- this is due to fact close lid will force to suspend - BUT I HAVE chosen not to do so.?!?!?! (by gnome-tweak ) 
then the screen is dimmed and not able to change


the same procedure but after reboot logged into my account
- close the lid - laptop is forced to suspend - after power up display is dimmed and no control on it


the same procedure but after reboot logged into my account
- prior to everything changing lid action to blank (even by installing gnome-tweak even from command line with gssetitngs) seems to change behavior - laptop will no more be forced to suspend
- this remain ok after reboot EXCEPT the moment before login
Comment 2 Lari Tanase 2012-01-04 18:45:40 EST
it has the same behavior on Fedora 16 latest upgrade

upgraded using PreUpgrade from 15
Comment 3 Blagoy Chepelov 2012-02-04 08:16:06 EST
Same bug in Fedora 16(fresh install).

gnome-power-manager-3.2.1-1.fc16.x86_64
Comment 4 Blagoy Chepelov 2012-02-05 09:13:46 EST
Hey guys,

Could the problem appears because of this:

[root@fedora16 cron.hourly]# pkexec /usr/libexec/gsd-backlight-helper --set-brightness 24
The value for the SHELL variable was not found the /etc/shells file

This incident has been reported.
--------------------------------------------------------------------------------
[root@fedora16 cron.hourly]# cat /etc/shells 
/sbin/nologin
/bin/dash
--------------------------------------------------------------------------------

Cheers
Comment 5 Thomas HAMEL 2012-03-25 08:02:29 EDT
(In reply to comment #4)

> [root@fedora16 cron.hourly]# pkexec /usr/libexec/gsd-backlight-helper
> --set-brightness 24
> The value for the SHELL variable was not found the /etc/shells file
> 
> This incident has been reported.
> -------------------------------------------------------------------------------


I see this bug on FC16 on my HP Mobile Workstation Elitebook 8530w. Only with the nouveau driver (Nvidia doesn't have this bug).

The command above works, if i suspend, it does not work anymore. the only way to restore brithness is to reboot.


$ cat /sys/class/backlight/acpi_video0/max_brightness 
24
$ cat /sys/class/backlight/acpi_video0/actual_brightness 
24
$ cat /sys/class/backlight/acpi_video0/bl_power 
0
$ cat /sys/class/backlight/acpi_video0/brightness 
24


I tried to set bl_power to 1, but no effect.
Comment 6 Josh Boyer 2012-03-28 14:01:50 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.
Comment 7 Josh Boyer 2012-06-06 12:44:55 EDT
Is this issue still being seen with the 3.3 update?
Comment 8 Blagoy Chepelov 2012-06-06 13:36:55 EDT
Nope, the issue is resolved in 3.3. Well sometimes in order to get the brightnes to the previous state I need to hold down the FN key and the brightnes up/down button.Anyway IMHO the issue is gone.
Comment 9 Josh Boyer 2012-06-06 14:22:19 EDT
Thanks for letting us know.
Comment 10 Thomas HAMEL 2012-06-06 15:42:18 EDT
I still have the issue on Fedora 17 with kernel 3.3.7-1.fc17.x86_64

backlight is off after suspend and hibernate.
Comment 11 Lari Tanase 2012-06-11 09:35:50 EDT
I can confirm also 
3.4.0-1.fc17.x86_64

the bug is present

not yet solved
Comment 12 Blagoy Chepelov 2012-06-21 12:32:00 EDT
Hey guys,

I have tested a couple of consecutive suspends/hibernates and every time I seem to fix the brightness level by pressing FN key and the brightnes up/down button or FN brightnesses button.
Some more info about my EliteBook 8530
Video:ATI 5700
Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz


 uname -a
Linux unknown 3.3.8-1.fc16.x86_64 #1 SMP Mon Jun 4 20:49:02 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 13 Justin M. Forbes 2012-12-07 11:07:50 EST
Is this still an issue with 3.6.9 kernels?
Comment 14 Blagoy Chepelov 2012-12-08 05:25:45 EST
Hey Justin,

I just installed and configured Fedora 18 on my EliteBook 8530w(ATI 5700
Intel(R) Core(TM)2 Duo CPU P8600  @ 2.40GHz) and the issue is gone.
$ uname -a
Linux localhost.localdomain 3.6.9-4.fc18.x86_64 #1 SMP Tue Dec 4 14:12:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

IMHO this could be closed.


Cheers

Note You need to log in before you can comment on or make changes to this bug.