Bug 72668 - package can not be build from sources
Summary: package can not be build from sources
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: compat-libs (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: package can not be build from sources...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-26 14:45 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 14:45:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-08-26 14:45:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I have tried to build package but I receive error with the next message:
cp: cannot stat `/usr/lib/libtclx[0-9]*.so': No such file or directory
error: Bad exit status from /users/nkrivits/try2-NEW/WORK_DIR/tmp/rpm-tmp.38060 
(%build)


This situation is due to error in "compat-libs.spec". Let's describe the next 
text from "Compat-libs.spec" :
for lib in %{LIBRARIES2} ; do
    cp -a /usr/lib/lib$lib[0-9]*.so /usr/lib/lib$lib.so .
done

If even one file with one figure in place of [0-9] is absent we have the error 
in command "cp" and the next diagnostic:
cp: cannot stat `/usr/lib/libtclx[0-9]*.so': No such file or directory.




In Red Hat 7.2 building passed due to file "/usr/lib/libtclx9.so" is presented.
In Red Hat 7.3 this file is absent.

I made workaround. I changed this fragment in compat-libs.spec to the next:
for lib in %{LIBRARIES2} ; do
    cp -a /usr/lib/lib$lib*.so /usr/lib/lib$lib.so .
done

   

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Unpack compat-libs-6.2-3.src.rpm to some local dir
2.Prepare sources (rpm -bp compat-libs.spec)

	

Additional info:

Comment 1 Jakub Jelinek 2002-08-26 14:48:58 UTC
compat-libs-6.2 (and other compat.*-6.2 packages) are to be built on Red Hat Linux 6.2,
not 7.x.


Note You need to log in before you can comment on or make changes to this bug.