Bug 726711 - Arch/Version information is never shown in 'My Installed Software'
Arch/Version information is never shown in 'My Installed Software'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Sefler
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-29 11:13 EDT by Michael Stead
Modified: 2011-12-06 12:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Version and Arch are now included in the candlepin generated certs (81.77 KB, image/png)
2011-07-29 14:26 EDT, John Sefler
no flags Details

  None (edit)
Description Michael Stead 2011-07-29 11:13:12 EDT
Description of problem:
Arch/Version information is never shown in 'My Installed Software'

Version-Release number of selected component (if applicable):
subscription-manager-0.96.4-1.git.67.570f1e8.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Launch subscription-manager-gui with product certs in /etc/pki/product
2. Ensure you are on the 'My Installed Software' tab.
  
Actual results:
Version and Arch is not displayed for installed products.

Expected results:
Version and Arch data should be displayed for each product.

Additional info:

Verified that this is because candlepin does not include the arch/version in the product certificate when it is created.
Comment 3 Michael Stead 2011-07-29 13:46:57 EDT
Fixed in candlepin master branch 04279aa2a44d356211a34069511f02d1e82a1a49

Nothing was wrong on the subscription manager end.


NOTE: Be sure that the new product certs are copied from candlepin's generated_certs (after running CP deploy script) into /etc/pki/product
Comment 5 John Sefler 2011-07-29 14:26:57 EDT
Created attachment 515920 [details]
Version and Arch are now included in the candlepin generated certs

Verifying Version...
[root@jsefler-onprem-62candlepin proxy]# git show-ref | grep master
04279aa2a44d356211a34069511f02d1e82a1a49 refs/heads/master
04279aa2a44d356211a34069511f02d1e82a1a49 refs/remotes/origin/master
Comment 6 errata-xmlrpc 2011-12-06 12:22:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.