Bug 72672 - Upgrade 7.3-> Null cant configure X
Upgrade 7.3-> Null cant configure X
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2002-08-26 11:39 EDT by Stephen John Smoogen
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-05-05 21:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Logfile from redhat-config-xfree86 (1.12 KB, text/plain)
2002-08-26 15:17 EDT, Stephen John Smoogen
no flags Details
Config file that the system created. (3.44 KB, text/plain)
2002-08-26 15:19 EDT, Stephen John Smoogen
no flags Details
XFree86.0.log from broke session (24.42 KB, text/plain)
2002-08-27 09:41 EDT, Stephen John Smoogen
no flags Details
Working log file after fresh install of RHL null. (28.79 KB, text/plain)
2002-09-04 15:16 EDT, Stephen John Smoogen
no flags Details
working VESA XF86config (3.24 KB, text/plain)
2002-09-04 15:18 EDT, Stephen John Smoogen
no flags Details
Working r128 XF86Config (no idea why) (3.03 KB, text/plain)
2002-09-04 15:19 EDT, Stephen John Smoogen
no flags Details

  None (edit)
Description Stephen John Smoogen 2002-08-26 11:39:12 EDT
Description of Problem:

Upgrade of 7.3-> Null on Inspiron 8000 with ATI Rage Mobility card. Cant
configure X after upgrade 

Trying to get XFree86 working seemed to cause some major problems.             
* ddcprobe returned bogus values:                                              
ID:   None                                                                     
Name: None                                                                     
HorizSync: None                                                                
VertSync:  None                                                                
* ddcprobe returned bogus values:                                              
ID:   None                                                                     
Name: None                                                                     
HorizSync: None                                                                
VertSync:  None                                                                
Couldn't start X server, trying with a fresh configuration                     
Traceback (most recent call last):                                             
  File "/usr/share/redhat-config-xfree86/xconf.py", line 1606, in ?            
    m = gtk.MessageDialog(None, gtk.DIALOG_MODAL, gtk.MESSAGE_WARNING,         
AttributeError: 'module' object has no attribute 'MessageDialog'               

I really dont know how to get a working X configuration on an laptop           
LCD. Doing an 'redhat-config-xfree86 --reconfig' gave me                       
* ddcprobe returned bogus values:                                              
ID:   None                                                                     
Name: None                                                                     
HorizSync: None                                                                
VertSync:  None                                                                
Error, cannot start X server.                                                  

Is there any fallback method to get a VESA or 'native' driver as was seen during
the upgrade? Otherwise, this is a non-usable upgrade :(.
Comment 1 Alexander Larsson 2002-08-26 14:26:11 EDT
Can you try redhat-config-xfree86 0.6.2 from rawhide?
Comment 2 Stephen John Smoogen 2002-08-26 14:38:53 EDT
Have upgraded to redhat-config-xfree86 0.6.2. The error is now:

* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Couldn't start X server, trying with a fresh configuration
Error, cannot start X server.

Here is the lspci -vvv output. The card supposedly has 16M onboard from the BIOS.

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M4 AGP
(prog-if 00 [VGA])
        Subsystem: Dell Computer Corporation: Unknown device 00a4
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop+ ParErr-
Stepping+ SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at e8000000 (32-bit, prefetchable) [size=64M]
        Region 1: I/O ports at cc00 [size=256]
        Region 2: Memory at fcffc000 (32-bit, non-prefetchable) [size=16K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [50] AGP version 2.0
                Status: RQ=31 SBA+ 64bit- FW- Rate=x1,x2,x4
                Command: RQ=0 SBA+ AGP- 64bit- FW- Rate=<none>
        Capabilities: [5c] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Comment 3 Alexander Larsson 2002-08-26 15:02:40 EDT
mharris? Do you know if there is anything strange with that video card?
Comment 4 Alexander Larsson 2002-08-26 15:03:18 EDT
smooge, can you attach your /var/log/XFree86.setup.log file.
Comment 5 Stephen John Smoogen 2002-08-26 15:17:24 EDT
Created attachment 73144 [details]
Logfile from redhat-config-xfree86
Comment 6 Stephen John Smoogen 2002-08-26 15:19:09 EDT
Created attachment 73145 [details]
Config file that the system created.
Comment 7 Stephen John Smoogen 2002-08-26 15:26:37 EDT
I am trying to get the redhat-config-xfree86 to use the default settings that
the monitor should understand (ie what were used during the install). Can you
give me those options?
Comment 8 Alexander Larsson 2002-08-27 04:40:23 EDT
I don't understand what X is saying here with "(EE) R128(0): No valid modes
found". The monitor as specified in that config file should support some of the
built in modes (such as the 800x600 it's been configured with). 

mharris: Any idea?

smooge: Do you have a working config file that we can compare with?

Comment 9 Stephen John Smoogen 2002-08-27 09:00:16 EDT
Sadly I dont thinks so. I had a previous bug with 54625. That meant I had a
working X with 7.1 and 7.2 that just flaked out if I moved from the X console to
the text ones and back. You can see in the attachments of that bug, we got the
XFree86 to detect modes and such. I didnt save that XF86 though :(. I will see
if I can replicate with 7.2 disks.
Comment 10 Stephen John Smoogen 2002-08-27 09:41:31 EDT
Created attachment 73304 [details]
XFree86.0.log from broke session
Comment 11 Stephen John Smoogen 2002-08-27 09:46:25 EDT
Ok at this point I am wondering if something is messed up in the Upgrade. (A
file left behind or something). Should I try a fresh install and see if the
problem still occurs?
Comment 12 Alexander Larsson 2002-08-27 10:55:58 EDT
It's really strange that it is throwing away all the default resolutions. Some
of them should be possible with that hsync/vsync. mharris?
Comment 13 Stephen John Smoogen 2002-09-04 12:54:51 EDT
I am reinstalling the box to see how it worked during the install. During the
install it didnt use the native driver but the VESA one. I am going to try and
fall back on this until a better idea/fix comes along.
Comment 14 Stephen John Smoogen 2002-09-04 15:15:39 EDT
Using VESA driver on Null allows for X to run after the install. I dont know why
the XFree86 - ATI r128 driver doesnt yet.. I saved the settings that I had and
try to reconfigure X using the r128 driver.

The system works correctly and without problems. At this point, I am thinking
that there is something in upgrading a default 7.3 machine to null that was
causing the problem. I am including in seperate attachments the 'working'
XFree86.0.log and XF86config (plus the working VESA one so that RH support will
have a file to mail people with problems).
Comment 15 Stephen John Smoogen 2002-09-04 15:16:39 EDT
Created attachment 74905 [details]
Working log file after fresh install of RHL null.
Comment 16 Stephen John Smoogen 2002-09-04 15:18:05 EDT
Created attachment 74907 [details]
working VESA XF86config
Comment 17 Stephen John Smoogen 2002-09-04 15:19:58 EDT
Created attachment 74908 [details]
Working r128 XF86Config (no idea why)
Comment 18 Stephen John Smoogen 2002-12-30 14:51:16 EST
Will test on 8.0.92 beta series this week. 
Comment 19 Brent Fox 2003-01-06 14:17:37 EST
Have you had any luck with Phoebe?
Comment 20 Stephen John Smoogen 2003-01-24 14:56:20 EST
Problem is worse now in 8.0.93. X does not come up in the install in vesa mode.
redhat-xfree86-config doesnt seem to be able to create a VESA mode screen that
works... and the old working configs do not work. (No screen found)
Comment 21 Stephen John Smoogen 2003-01-26 15:17:08 EST
What I have tried:

linux lowres
linux resolution=1024x786

All of these failed. However, trying Dr. Mikes suggestion of 

linux resolution=1400x1050

resulted in a graphical install. I am going to see if this will allow for
further X configuration later.
Comment 22 Brent Fox 2003-02-07 01:09:17 EST
This looks basically similar to bug #81436.  See my post from 02/06/2003 on what
I think is happening with the Inspiron 8000.

If you have a chance, upgrade to the latest r-c-xfree86 from Rawhide and try the
following steps:

1) Move your existing /etc/X11/XF86Config file out of the way
2) Run 'redhat-config-xfree86 --set-hsync='31.5-90.0' --set-vsync='59.0-85.0'
3) See if an /etc/X11/XF86Config file was created
4) See if that file works. 

Sigh.  I can't help but think that we could find a better solution if we
actually had an Inspiron 8000 in the test lab.  
Comment 23 Brent Fox 2003-04-14 15:32:54 EDT
Any luck with the final release of RHL 9?
Comment 24 Stephen John Smoogen 2003-04-14 16:01:22 EDT
I will have to try a fresh install again. It worked at one point during the
betas and I must have replied about it on another bug report. I will try to test
it this evening and report back.
Comment 25 Brent Fox 2003-04-25 11:53:49 EDT
Ok, let me know how it goes.  I'm trying to clean up my Bugzilla list for bugs
that may have already been fixed but were never closed.
Comment 26 Stephen John Smoogen 2003-05-05 21:26:45 EDT
THis bug can be closed for me. 9 installs and upgrades without issues.

Note You need to log in before you can comment on or make changes to this bug.