Bug 726739 - libguestfs: error: aug_get: no matching node, trying to find hostname
libguestfs: error: aug_get: no matching node, trying to find hostname
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-29 12:33 EDT by Richard W.M. Jones
Modified: 2011-07-29 12:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-29 12:39:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-07-29 12:33:38 EDT
Description of problem:

is_file "/etc/sysconfig/network" = 1
filesize "/etc/sysconfig/network" = 34
aug_init "/" 48 = 0
aug_rm "/augeas/load//incl[. != "/etc/sysconfig/network"]" = 0
aug_load = 0
aug_get "/files/etc/sysconfig/network/HOSTNAME" = NULL (error)
libguestfs: error: aug_get: no matching node

Version-Release number of selected component (if applicable):

libguestfs 1.8.8
inspecting CentOS 5.5 guest

The problem is that the /etc/sysconfig/network file does
not contain the expected HOSTNAME entry.  This should not
cause inspection to fail.

Note You need to log in before you can comment on or make changes to this bug.