Bug 72675 - Virtual Host editor has dead file dialog
Virtual Host editor has dead file dialog
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 11:51 EDT by Steve Fox
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 09:32:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2002-08-26 11:51:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
The Virtual Host editor's Document Root Directory file picker creates a dialog
box that doesn't respond to the mouse or keyboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a new virtual host
2. Click the Browse button for the Document Root Directory
3. Try to play with file dialog. 

Actual Results:  The window is stuck and won't even close. No response to
keyboard or mouse input.

Expected Results:  Should be able to select a directory.

Additional info:

redhat-config-httpd-1.0.1-11
Comment 1 Phil Knirsch 2002-09-02 09:32:17 EDT
Seems to be a bug in gtk2 or glade2 rather than in redhat-config-httpd. I've
tested it with some sampel code, and using a GtkFileEntry doesn't work for
subdialogs with are modal :-(

I might simply as a quick fix disable the subdialog file entries for now. Not
nice, but at least won't result in unexpected behaviour.

Read ya, Phil
Comment 2 Phil Knirsch 2002-09-03 08:41:56 EDT
OK, temporary fix is in the laste redhat-config-httpd-1.0.1-13 which disables
the fileselector for modal subdialogs and replaces them with simple GtkEntry
widgets.

Not very pretty, but at least it works again that way.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.