Bug 726791 - Activate a Subscription => Redeem a Subscription
Activate a Subscription => Redeem a Subscription
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-29 16:00 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Activate should be Redeem (53.35 KB, image/png)
2011-07-29 16:00 EDT, John Sefler
no flags Details
verification of Activation => Redeem rename (78.14 KB, image/png)
2011-08-02 10:17 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-07-29 16:00:08 EDT
Created attachment 515927 [details]
Activate should be Redeem

Description of problem:
The terminology for activating a DELL machine was recently changed in the subscription-manager-cli from "activate" to "redeem".  This same change should be made in the subscription-manager-gui

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.96.4-1.git.67.570f1e8.el6.x86_64

How reproducible:


Steps to Reproduce:
1. add the following to /etc/candlepin/candlepin.conf on your on premises candlepin server and restart candlepin
candlepin.subscription.activation.debug_prefix = redemption

2. register using using --name=redemption90210
subscription-manager register --username=testuser1 --password=password --org=admin --name=redemption90210

3. start subscription-manager-gui
  
Actual results:
see attached screenshot

Expected results:


Additional info:

[root@jsefler-onprem-62server ~]# subscription-manager redeem --help
Usage: subscription-manager redeem [OPTIONS]

Attempt to redeem a subscription for a preconfigured machine

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy url in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for http proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for http proxy with basic authentication
  --email=EMAIL         optional email address to notify when subscription
                        activation is complete.
  --locale=LOCALE       optional language to use for email notification when
                        subscription activation is complete. Used with --email
                        only. Examples: en-us, de-de
Comment 1 Bryan Kearney 2011-08-01 16:46:35 EDT
Fixed in master at 34d388faaf2124edf5036e74ca49cdd8db7d5250 (merge is at 57441fbd6a287c84714f2e37d836621484c4f02e). 

One question, I get a permission denied when I do this. Is this another bug?
Comment 4 John Sefler 2011-08-02 10:17:12 EDT
Created attachment 516326 [details]
verification of Activation => Redeem rename

Look at the screenshot -still need an edit to a candlepin error message:

Standalone candlepin does not support activation.

Suggestions:
Standalone candlepin does not support redeeming a subscription.
Standalone candlepin does not support subscription redemption.
Comment 5 Bryan Kearney 2011-08-02 13:02:31 EDT
Chris Duryee fixed this in 58115c1f of candlepin in master.
Comment 6 John Sefler 2011-08-02 15:29:19 EDT
[root@jsefler-onprem-62candlepin proxy]# git show-ref | grep master
871561942eff39dbea6bed09521b3c5a57476aaa refs/heads/master
871561942eff39dbea6bed09521b3c5a57476aaa refs/remotes/origin/master

[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.80.a26379e.el6.x86_64

Testing against an on-premises candlepin server...

[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
The system has been registered with id: c3dd0dbe-afbc-42dc-be44-f865ee98e264 
[root@jsefler-onprem-62server ~]# subscription-manager redeem --email=tester@redhat.com
Standalone candlepin does not support redeeming a subscription.

^^^^ candlepin error message verified (and gui was verified in attachment 516326 [details])

Moving to VERIFIED
Comment 7 errata-xmlrpc 2011-12-06 12:22:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.