Bug 7268 - Installation fails with Exception while searching for RPMs
Installation fails with Exception while searching for RPMs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-23 18:31 EST by Michael Cortez
Modified: 2015-01-07 18:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-29 11:49:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cortez 1999-11-23 18:31:43 EST
Installing on an old Sparc IPC system, via Anonymous FTP (ftp.redhat.com)

Selected Server Install, set TimeZone, Set Root password, and created a
user, then ...

The system reported "Reading Packages" and then halts with a "Exception
Occured" error.

----------------------
Traceback (innermost last):
File "/usr/bin/anaconda.real", line 230, in ?
intf.run(todo, test = test)

File "/tmp/lib/python1.5/site-packages/text.py", line 1038, in run

...
Etc, etc
----------------------

Then I am presented with "OK" and "DEBUG"

"OK" shuts down the system, debug appears to bring up some kind of
debuger...
Comment 1 Frank C. Brants 1999-11-25 04:22:59 EST
I have replicated this error using the 1474560 Nov 16 14:13 boot32.img on a SS20
doing anon ftp install from another sparc on my LAN.  The installer crashes
during rpm fetch & install phase... not sure if it's the same spot.  Oddly
enough, my first 6.1 install on this machine went fine.  I've since added a new
drive & been unable to repeat the install.  Feel free to mail me for more
details.

Thanks!!

Franko
Comment 2 Frank C. Brants 1999-11-25 13:08:59 EST
Just checked my ftp logs, looks like my install keeps dying in the same spot

Thu Nov 25 08:24:55 1999 1 ss20.ashe84.com 662699 /pub/RedHat/RPMS/gnuchess-4.0.
pl80-2.sparc.rpm b _ o a anonymous@localhost.localdomain ftp 0 *
Thu Nov 25 08:24:58 1999 1 ss20.ashe84.com 150850 /pub/RedHat/RPMS/libxml-1.4.0-
1.sparc.rpm b _ o a anonymous@localhost.localdomain ftp 0 *

Thu Nov 25 10:40:22 1999 1 ss20.ashe84.com 662699 /pub/RedHat/RPMS/gnuchess-4.0.
pl80-2.sparc.rpm b _ o a anonymous@localhost.localdomain ftp 0 *
Thu Nov 25 10:40:26 1999 1 ss20.ashe84.com 150850 /pub/RedHat/RPMS/libxml-1.4.0-
1.sparc.rpm b _ o a anonymous@localhost.localdomain ftp 0 *

The last lines of the traceback looks like this...

"var/tmp/python-root/usr/lib/python1.5/ftplib.py", line 201, in getresp IOError:
[Errorno ftp error] [Errno ftp error] 550 zlib-1.1.3-5.sparc.rpm: No such file
or directory.

I checked & the file it's looking for is indeed missing...

[root@mail RPMS]# ls zlib*
-rw-r--r--   1 root     ftp         66603 Nov 16 15:08
zlib-devel-1.1.3-5.sparc.rpm
[root@mail RPMS]#

I went up to ftp.redhat.com & the file is there, somehow it was skipped during
the download.

> ls zlib*

zlib-1.1.3-5.sparc.rpm
zlib-devel-1.1.3-5.sparc.rpm
ftp.redhat.com                             /pub/redhat/current/sparc/RedHat/RPMS
redhat>

Only one question remains, why was it looking for zlib when it looks like it
normally does everything in alphabetical order.

Hope this helps,

Franko
Comment 3 Frank C. Brants 1999-11-25 23:18:59 EST
Using ncftp, I re-downloaded the entire /RedHat tree.  Ncftp only pulled the
files I was missing.  Tried the install again & it worked fine.

Hope this helps.  I sent mail to the sparc-list about how to fix the problem.
Bugzilla is a very usefull tool!!

Franko
Comment 4 Jay Turner 1999-11-29 11:49:59 EST
We will work to put together a little better error handling for stuff like this
so that you do not have to go rooting around in logs to determine what happened.
Comment 5 Stuart Blake Tener 1999-12-17 18:35:59 EST
THE BUG AINT OVER TILL THE THIN MAN SINGS!

I must admit, I read this bug, and beleive it to still exist. I recently
from (a day or two ago) the redhat ftp site downloaded the ISO image for
the SPARC version of RH6.1.

I think it means that the current ISO image of the SPARC can be flushed!

Well, need I say more? I am not posting here cause it worked! I am sure
you figured that much out.

My configuration: SPARC 2, 1GB Fitjutisu SCSI DR, 16MB RAM

I attempted to begin the install, and it got a point where it said something
like, oh g-d, you have so little ram, hurry up lets make a swap partition.
This came after I had used the fdisk screens to create the partitioning info
for the drive. It then put a message like "Formatting swap partition...".

The next thing I saw was:

Traceback (innermost last);
  File "/usr/bin/anaconda", line 238, in ?
intf.run(todo, test = test)
File
"/usr/lib/python1.5/site-packages/text.py", line 238, in run
RC = apply(step[1](), step[2])
File
"/usr/lib/python1.5/site-packages/textw/pa.py", line 171, in __CALL__
todo.makefilesystems ( createfs = 0 )
File

If a bug and half is pressed into a cdrom and half in a day in and half,
and it happens twice to the same stock holder, the company looses money
do you think he will show up at the stock holders meeting and raise holly hell?

In other words, this is the third major bug in the installation script which
was not found prior to release in the last few months with RH6.1. I have had
the raw experience of two out of three. Thank g-d, I bagged Solaris a year ago
or I'd a really been upset.

This bug, along with the Solaris swap, and NT partition bugs, could all have
been prevented with one small item: QUALITY CONTROL.

Dont get me wrong, I have the deepest respect for RedHat, and as a consultant
continue to recommend it as a solution for customers.

Note You need to log in before you can comment on or make changes to this bug.