Bug 72688 - mozilla needs current glibc as prereq
mozilla needs current glibc as prereq
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
8.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 13:56 EDT by Bert de Bruijn
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bert de Bruijn 2002-08-26 13:56:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
when mozilla is installed before the new (current) glibc is installed,
/usr/lib/mozilla-1.0.1/regxpcom can not be run and
/usr/lib/mozilla-1.0.1/component.reg can not be created. Both mozilla and galeon
will fail to run if this file is missing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start with redhat 7.3
2. upgrade mozilla/galeon with all dependencies but not glibc (which is not an
explicit prereq)
3. try starting mozilla or galeon
4. rpm -V mozilla
5. run /usr/lib/mozilla-1.0.1/regxpcom

Actual Results:  mozilla/galeon cannot start (failed to initialize mozilla
libraries) because the component.reg file is missing or empty.
rpm -V mozilla shows something wrong with component.reg.
/usr/lib/mozilla-1.0.1/regxpcom gives a library error, and cannot run.

Expected Results:  component.reg should be remade by
/usr/lib/mozilla-1.0.1/mozilla-rebuild-databases.pl (in the post-install
scripts). The script is run, but the binaries don't work with older glibc's.

Additional info:

This is not a problem in a full install or full upgrade. It can give problems in
manual upgrade (because the rpm prereqs don't force the correct installation
order and dependencies).

Note You need to log in before you can comment on or make changes to this bug.