This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 72689 - Conflicts and Provides in under the same package isn't smart enough not to detect a conlfict
Conflicts and Provides in under the same package isn't smart enough not to de...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
http://www.jpackage.org/rpm/free/ant/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 13:58 EDT by Christian Pearce
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-28 09:03:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Pearce 2002-08-26 13:58:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020713

Description of problem:
The following package in the url is the package.  If you go to the jpackage.org
site and examine the spec file you will notice they have two packages. 
ant-optional and ant-optional-full.  The ant-optional-full contains the same
libraries as ant-optional full, different filenames, but the full has more
compiled into it.

Since jpackage is providing the same package as ant-optional in there rpm
namespace with ant-optional-full they put the provides: ant-optional tag.  Make
sense.  Now you don't want to have them both install at the same time so they
put in a Conflicts: ant-optional.  When you go to do an install you get the
following :

[pearcec@mp3 a]$ sudo rpm -Uvh ant-optional-full-1.5-4jpp.noarch.rpm 
error: failed dependencies:
	ant-optional conflicts with ant-optional-full-1.5-4jpp

rpm should smart enough to allow this during the install.  Some flag in the
code.  If the package installing provides and conflicts the same package it
should allow it to install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
The description above should be enough to understan the problem.
	

Additional info:
Comment 1 Jeff Johnson 2002-12-28 09:03:15 EST
Yup, that's the way conflicts is supposed to work.

Some means other than "smarter rpm" and Conflicts: is needed to
package the minimal -> full upgrade path as described.

In fact, I suspect that adding Obsoletes: to each package
to eliminate the other is closer to the desired behavior.

Note You need to log in before you can comment on or make changes to this bug.