Bug 72693 - Glade stock menu items not translated correctly
Glade stock menu items not translated correctly
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-python2 (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks: 65866 66350 71792
  Show dependency treegraph
 
Reported: 2002-08-26 14:12 EDT by Daniel Walsh
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 10:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case showing the problem (1.82 KB, patch)
2002-08-26 14:14 EDT, Daniel Walsh
no flags Details | Diff

  None (edit)
Description Daniel Walsh 2002-08-26 14:12:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020712

Description of problem:
Stock Menu items within the glade/gnome widget pool are not being translated
correctly.  Menu items do not show for certain languages.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run Glade-2 and build a new gnome app
2.Select the gnome app window and save.
3.Now build a python module to use the glade file.
4.Run the glade module with the following command
LANG=jp_JP.eucJP python2.2 test.py

	

Actual Results:  Translated menu line will not appear.

Expected Results:  Translated menu line should appear.

Additional info:
Comment 1 Daniel Walsh 2002-08-26 14:14:37 EDT
Created attachment 73124 [details]
test case showing the problem
Comment 2 Havoc Pennington 2002-08-26 14:43:46 EDT
Have a look at e.g. redhat-config-packages. We seem to have a little convenience
module rhpl.translate that handles some of the details.

Comment 3 Daniel Walsh 2002-08-27 14:26:51 EDT
I don't believe any of the rhpl/translate routines will help.  The problem here
is not english words in my code that are not being translated, but english words
within the glade stuff that is not being translated.  Stock item _About does not
have a corresponding _("About") in my code.

Comment 4 Jonathan Blandford 2002-08-27 14:46:26 EDT
the problem is that gnome.ui.program_init is not calling bindtextdomain on
libgnomeui.  Matt, do you have a fix forthcoming?
Comment 5 Jonathan Blandford 2002-09-02 12:28:23 EDT
this is fixed in the current libgnome package

Note You need to log in before you can comment on or make changes to this bug.