Bug 72696 - up2date selects athlon kernel packages after fresh 7.2 install
Summary: up2date selects athlon kernel packages after fresh 7.2 install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-26 18:31 UTC by Phil D'Amore
Modified: 2008-05-01 15:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 19:00:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Phil D'Amore 2002-08-26 18:31:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020524

Description of problem:
Upon performing a fresh install of RHL 7.2, up2date --update --force is run,
causing the following:

[root@foo root]# up2date --update --force

Retrieving list of all available packages...
########################################

Removing installed packages from list of updates...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
RPM conflict error.  The message was:
Test install failed because of package conflicts:
package kernel-2.4.9-34 is for a different architecture


Upon examining /var/spool/update, I get this:

[root@foo root]# ls /var/spool/up2date/kernel-*
/var/spool/up2date/kernel-2.4.9-34.athlon.hdr
/var/spool/up2date/kernel-smp-2.4.9-34.athlon.hdr

On my i686 machine, I am apparently getting athlon kernel package headers.  So,
I tried to update up2date first, using:

up2date up2date

After that, the proper kernel is selected, and the update proceeds normally.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install fresh system and register w/ RHN.
2.  Run up2date --update --force, and note that update fails with error message
in description:

RPM conflict error.  The message was:
Test install failed because of package conflicts:
package kernel-2.4.9-34 is for a different architecture

And notice the athlon kernel headers are downloaded to /var/spool/up2date.

3.  Manually update up2date:

up2date up2date

4.  Re-run the up2date --update --force, and notice that the kernel is properly
selected this time.

Expected Results:  The default up2date should be selecting the proper kernel
architecture.

Additional info:

Comment 1 Mihai Ibanescu 2002-08-26 18:59:57 UTC
Client bug triggered from a server-side change. Will push new server code ASAP.
Workaround: up2date up2date.

Comment 2 Josef Komenda 2002-10-24 16:07:07 UTC
Fixed, closing.


Note You need to log in before you can comment on or make changes to this bug.