Bug 727 - can't negotiate a ppp-connection when using the generic kernel (releases 1 and 3)
Summary: can't negotiate a ppp-connection when using the generic kernel (releases 1 an...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-07 16:52 UTC by daniel.tweedt
Modified: 2015-10-30 14:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-07 18:08:10 UTC


Attachments (Terms of Use)

Description daniel.tweedt 1999-01-07 16:52:51 UTC
Using the generic kernel for releases 1 and 3 (and maybe
0.7?) I get an error message when trying to establish a
ppp-connection with my ISP. When I rebuild the kernel then
it works fine. I'm not sure if it's significant, but all the
kernels that I've built have ISND (and SCSI) support
removed. Also, I checked the module dependencies (for ppp,
slhc, slip) with both the generic and rebuilt kernels, and
they appear to be the same.

Comment 1 David Lawrence 1999-01-07 17:03:59 UTC
we will need to see an output of you kernel messages when you are
trying to make a ppp connection. You can do this by typing

tail /var/log/messages

after it fails. Then provide that output to the bugzilla system.

Comment 2 daniel.tweedt 1999-01-07 17:36:59 UTC
It looks like the kernel is looking in the wrong place; it should be
looking for the module dependencies in /lib/modules/preferred or
/lib/modules/2.0.36-3

Jan  6 21:25:04 sonic modprobe: no dependency information for module:
"/lib/modules/2.0.36/net/ppp.o"
Jan  6 21:25:04 sonic last message repeated 2 times
Jan  6 21:25:04 sonic pppd[1420]: ioctl(TIOCSETD): Invalid
argument(22)
Jan  6 21:25:04 sonic pppd[1420]: This system lacks kernel support for
PPP.  This could be because the PPP kernel module is not loaded, or
because the kernel is not configured for PPP.  See the README.linux
file in the ppp-2.3.5 distribution.
Jan  6 21:25:04 sonic modprobe: no dependency information for module:
"/lib/modules/2.0.36/net/ppp.o"

Comment 3 Jeff Johnson 1999-01-07 18:08:59 UTC
The path /lib/modules/2.0.36 indicates that you are not loading
modules from a  Red Hat kernel. Try doing
	mv /lib/modules/2.0.36 /lib/modules/2.0.36-SAVE
and see if your problem is resolved. If so, you might
take a look at problem #96 which describes a modultils bug
that may be affecting you.

Please reopen this bug if you still have a problem.

Comment 4 openshift-github-bot 2015-10-30 14:30:21 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/2ce8ce1557060f01a357ad96ad3318bae2ce5bca
Merge pull request #1072 from tpoitras/github-issue-727-LabelsPresence

added true/false info and context for LabelsPresence [issue 727]


Note You need to log in before you can comment on or make changes to this bug.