Bug 72700 - PHP scripts no longer run after updating PHP
PHP scripts no longer run after updating PHP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 14:58 EDT by john.l.villalovos
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 14:58:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john.l.villalovos 2002-08-26 14:58:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020818

Description of problem:
I updated PHP to php-4.1.2-7.3.3 on Red Hat 7.3.  Now, none of the *.php files
will execute as PHP files on my web pages.  I have looked at for a while and I
don't have a clue why this is happening.  It has happenned on more than one
system running Red Hat 7.3

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create an index.php file in a web server directory
2. Go to the corresponding URL.
3. PHP does not run :(
	

Additional info:
Comment 1 Phil Copeland 2002-08-26 15:34:40 EDT
I'm fairly certain they won't run because they use the
<?
...
?>

syntax as opposed the to the correct
<?php
...
?>
syntax

edit /etc/php.ini
look for

; Allow the <? tag.  Otherwise, only <?php and <script> tags are recognized.
short_open_tag = On

and change that to off and they should get you back to where you were before

Strictly speaking your scripts should open/close with <?php ... ?>

Phil
=--=
Comment 2 john.l.villalovos 2002-08-26 15:39:07 EDT
Woo hoo!  That was it.  Thanks for the help on that.
Comment 3 Adam H. Pendleton 2003-01-07 11:42:17 EST
While it may be correct in the technical sense, there are many, many PHP 
packages which use the "<?" syntax as opposed to "<?php".  Since this setting 
has been back-ported to 7.3 and also affects all 8.0 systems, wouldn't it be a 
better idea to leave the option on, considering the plethera of PHP packages 
that are now effectively broken because of this setting?  There has been quite 
a bit of confusion about this setting on the mailing lists, as well as many of 
customers complaining about PHP no longer working on their systems.  Being 
pedantic doesn't seem to be a good reason to cause as much damage as this 
change does.
Comment 4 Joe Orton 2003-01-07 11:46:06 EST
Yes - the short_open_tag default has been changed back to "On" in the Phoebe
beta release.

Note You need to log in before you can comment on or make changes to this bug.