Bug 727034 - [WHQL][viostor]winxpsp3 32 bit guest exited with "virtio: trying to map MMIO memory" error
Summary: [WHQL][viostor]winxpsp3 32 bit guest exited with "virtio: trying to map MMIO ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 6.2
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard: virtio-block
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-01 05:38 UTC by Sibiao Luo
Modified: 2011-12-06 21:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Do not document.
Clone Of:
Environment:
Last Closed: 2011-12-06 21:17:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1542 normal SHIPPED_LIVE virtio-win bug fix update 2011-12-07 02:13:14 UTC

Description Sibiao Luo 2011-08-01 05:38:54 UTC
Description of problem:
After installing drivers, the VM guest failed with "virtio: trying to map MMIO memory" error when boot the VM guest with virtio-blk-pci.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-13
kernel-2.6.32-171.el6.x86_64
qemu-kvm-0.12.1.2-2.172.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Install guest with ide-driver & rtl8139 nic(Need 1 system disk and 4 data disks).
eg:
/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=winxp-activate-0706.raw,format=raw,if=none,id=drive-virtio0,boot=on,cache=none,werror=stop,rerror=stop -device ide-driver,drive=drive-virtio0,id=virtio-blk-pci0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device rtl8139,netdev=hostnet0,mac=00:11:1c:16:73:35 -boot c -uuid 57b96439-3615-48c4-81f4-f6e2dd8e1e77 -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-winxp-blk-sluo,server,nowait -mon chardev=111a,mode=readline -name winxp-blk-sluo-13 -vnc :1 -drive file=disk1.raw,format=raw,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.raw,format=raw,if=none,id=drive-virtio2,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.raw,format=raw,if=none,id=drive-virtio3,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.raw,format=raw,if=none,id=drive-virtio4,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4
2.Update system,donwload symbols,and then confirm a successful symbols installation.
3.Boot the guest with virtio-blk-pci.
(1)Change computer name.
(2)Close guest firewall
(3)Install/Update virtio block driver to the latest one,the driver located in install\Wxp\x86\storage.
(4)Install DTM Client.
(5)Format the 4 disks.
 
Actual results:
The VM guest failed with"virtio: trying to map MMIO memory" error.

Expected results:
Driver can be updated successfully and the guest run without any errors.

Additional info:
processor	: 15
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Xeon(R) CPU           E5520  @ 2.27GHz
stepping	: 5
cpu MHz		: 2260.952
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 sse4_2 popcnt lahf_lm ida dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 4521.30
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management:

Comment 2 Mike Cao 2011-08-02 02:56:42 UTC
add testblocker keyword ,it blocks QE to run virtio block whql test .

additional info :
only occurs with winxp 32 bit guest .

Comment 4 Vadim Rozenfeld 2011-08-10 21:15:55 UTC
Please verify with the latest drivers from:
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/15/win/virtio-win-prewhql-0.1.zip

Thank you,
Vadim.

Comment 5 Min Deng 2011-08-12 07:01:39 UTC
Hi Vadim,
   Actually,QE have already begun to verify the bug while hitting an issue at step 3.Boot the guest with virtio-blk-pci.
   After system disk was changed from 'ide' to 'virtio' the guest could not boot up successfully.It should be a new bug and it will be reported just a moment.
   Now we are tying another way to verify this bug.Thank you very much.

Best regards,
Min

Comment 6 Vadim Rozenfeld 2011-08-12 07:20:45 UTC
(In reply to comment #5)
> Hi Vadim,
>    Actually,QE have already begun to verify the bug while hitting an issue at
> step 3.Boot the guest with virtio-blk-pci.
>    After system disk was changed from 'ide' to 'virtio' the guest could not
> boot up successfully.It should be a new bug and it will be reported just a
> moment.
>    Now we are tying another way to verify this bug.Thank you very much.
> 
> Best regards,
> Min

Hi Min,
Did you use the latest driver installing the system at stage 1?
Thank you,
Vadim.

Comment 8 Mike Cao 2011-08-12 08:08:49 UTC
(In reply to comment #6)

> Hi Min,
> Did you use the latest driver installing the system at stage 1?
> Thank you,
> Vadim.

I make a floppy which newest viostor driver for winxp in it .QE will try to make whether it is work

Comment 9 Sibiao Luo 2011-08-12 11:32:55 UTC
Hi,
 I have tried two mothods to verify with the latest drivers,and the issue didn't reproduc on the  virtio-win-prewhql-0.1-15.But there is a new bug(Bug 730223).

First mothods:
   1.Boot guest with IDE driver with the floppy of virtio-win-1.3.3-0.el6.
eg:/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=winxp-new.raw,format=raw,if=none,id=drive-virtio0,cache=none,werror=stop,rerror=stop -device ied-drive,drive=drive-virtio0,id=virtio-blk-pci0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device rtl8139,netdev=hostnet0,mac=00:11:1c:16:73:35 -boot c -uuid 5395b4ef-f341-4d6c-87ca-94291c7cd200 -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-winxp-blk-sluo,server,nowait -mon chardev=111a,mode=readline -name winxp-blk-sluo-13 -spice disable-ticketing,port=5966 -vga qxl -drive file=disk1.raw,format=raw,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.raw,format=raw,if=none,id=drive-virtio2,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.raw,format=raw,if=none,id=drive-virtio3,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.raw,format=raw,if=none,id=drive-virtio4,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4 -monitor stdio -drive file=/usr/share/virtio-win/virtio-win-1.3.3.vfd,if=none,id=f1,format=raw,cache=none -global isa-fdc.driveA=f1
   2.update the data disk to latest driver(virtio-win-prewhql-0.1-15)
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/15/win/virtio-win-prewhql-0.1.zip
   3.shut down the guest and change ide-driver to virtio-blk-pci for system
disk
   4.boot guest successfully.

Second mothods:
   1.make a floppy which is the newest viostor driver(virtio-win-prewhql-0.1-15) for winxp
   1.Boot guest with virtio-blk-pci with the floppy of virtio-win-prewhql-0.1-15
eg:/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=xpbug.raw,format=raw,if=none,id=drive-virtio0,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device rtl8139,netdev=hostnet0,mac=00:11:1c:16:23:35 -boot dc -uuid a89628ba-c3d5-435f-97f5-e566d42942eb -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-winxp-blk-sluo,server,nowait -mon chardev=111a,mode=readline -name winxp-blk-sluo-13 -spice disable-ticketing,port=5965 -vga qxl -drive file=disk1.raw,format=raw,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.raw,format=raw,if=none,id=drive-virtio2,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.raw,format=raw,if=none,id=drive-virtio3,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.raw,format=raw,if=none,id=drive-virtio4,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4 -monitor stdio -drive file=/virtio_viostor.img,if=none,id=f1,format=raw,cache=none -global isa-fdc.driveA=f1 -cdrom en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso
   2.install the the latest driver with four data disks from the floppy.
   3.shut down the guest and then boot guest successfully.

Comment 10 Mike Cao 2011-08-15 09:54:17 UTC
Based on comment #9 ,move status to Verified.

Comment 11 gvenkat 2011-09-30 02:19:48 UTC
Please note that this bug has been reported in many other distros as well including my report for opensuse.

Please see

https://bugs.launchpad.net/qemu/+bug/818673
https://bugzilla.novell.com/show_bug.cgi?id=704537


One thing that might help in reproducing the bug is to know that this crash happens for me only on the first boot of the guest after a reboot of the host. The subsequent start of the guest works with no problems.

Any attempts to reproduce this problem must be after a reboot of the host to be sure. (there may be other software restarts/resets that might show the problem but a host reboot is a reliable way of reproducing the problem).

Comment 12 Vadim Rozenfeld 2011-11-02 20:09:07 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Do not document.

Comment 13 errata-xmlrpc 2011-12-06 21:17:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1542.html


Note You need to log in before you can comment on or make changes to this bug.