Bug 72704 - RFE: up2date needs to return usable error codes
RFE: up2date needs to return usable error codes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 15:13 EDT by Todd Warner
Modified: 2008-07-22 11:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 11:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Warner 2002-08-26 15:13:36 EDT
It would be nice if up2date (and I assume rhn_register) both returned
error/status codes upon exit. There is no way to scriptically determine the
outcome of the process.
Comment 1 Todd Warner 2003-03-21 16:31:59 EST
I added sys.exit(main() or 0) to up2date's wrapper.py, which helps (i.e., a
return code will always be returned. Need to do the same for rhn_register and
rhn_check before moving this to MODIFIED.
Comment 2 Todd Warner 2003-05-09 09:02:38 EDT
Note: gtk/glade hijack sys.exit. You can sys.exit whatever you want and
gtk/glade will exit with their own exit codes (which is never what you want).
Comment 3 Todd Warner 2004-09-16 00:53:36 EDT
nice two year old bug without a comment from the assignee.
status?
Comment 4 Todd Warner 2004-12-10 11:33:17 EST
From a customer:
"""
 Can you make the return code of up2date be non-zero when RHN is down?



$ sudo up2date --showall
https://xmlrpc.rhn.redhat.com/XMLRPC
IMPORTANT MESSAGE FOLLOWS:

Red Hat Network is currently experiencing technical difficulties.

We apologize for any inconvenience this outage may cause.

Thank you for using Red Hat Network.

--the RHN team

ksa@rhupdate1 AFS-Admin $ echo $?
0
"""
https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=48350

Bumping priority to high for this reason.
Comment 8 Beth Nackashi 2007-02-20 15:39:27 EST
RHN needs the following information to be provided by the customer:
1- which version of RHEL are they using?
2- which version of up2date are they using?

... because this problem is not reproducible in any versions of RHEL4.  This
should thus be removed from the RHEL4.5 blocker list.
Comment 10 Red Hat Bugzilla 2007-04-11 20:05:41 EDT
User bnackash@redhat.com's account has been closed

Note You need to log in before you can comment on or make changes to this bug.