Bug 72720 - Anaconda loads a i386 kernel when i586 required
Anaconda loads a i386 kernel when i586 required
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i586 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 18:27 EDT by Karl F. Larsen
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 19:33:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl F. Larsen 2002-08-26 18:27:14 EDT
Description of Problem:Anaconda is loading a i386 kernel which is not a DRI
kernel and the Voodo video card is not getting it's driver. See bug 72084


Version-Release number of selected component (if applicable):
The one shipped with version 7.3 

How Reproducible:
Every time

Steps to Reproduce:
1.Load version 7.3 
2. ask for a large X window
3. Get a unstable small X window

Actual Results:
Bad X window setup

Expected Results:
Solid 1024X768 X window

Additional Information:
Comment 1 Karl F. Larsen 2002-08-26 19:33:23 EDT
I used a test given me and the i386 kernel is loaded. I checked and linux calls
my computer an i586 machine. Then I looked on all three installation CD-Roms and
there is no kernel-2.4.18-3.i586.rpm on any of them. It appears that anaconda
could not have installed this file in anycase since it doesn't exist.

The problem is that the kernel anaconda loaded does not have DRI support and so
the driver for my video card and all the sound things are not loaded.

I tried to load kernel-2.4.18-3.i686 which does exist but it would not load.
Comment 2 Jeremy Katz 2002-08-26 21:15:07 EDT
7.3 did not ship with an i586 kernel.  I believe that there is one in the
current errata.  Future releases have an i586 kernel.
Comment 3 Karl F. Larsen 2002-08-27 08:30:01 EDT
I will look for a plain full kernel 2.4.18 and compile the dam thing myself.
Comment 4 Karl F. Larsen 2002-08-27 18:16:17 EDT
Hi guys, well I downloaded the proper kernel and loaded it and got the tdfx
module working. 

Now have a 1280X1024 X windows stable and I'm a happy camper. Thanks for your
most necessary support!

Note You need to log in before you can comment on or make changes to this bug.