Bug 72721 - anaconda doesn't like NVIDIA nForce graphics
anaconda doesn't like NVIDIA nForce graphics
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 18:39 EDT by Vasco Alexandre da Silva Costa
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-21 06:20:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvn (7.79 KB, text/plain)
2002-09-01 13:10 EDT, Vasco Alexandre da Silva Costa
no flags Details
lspci -vv (8.93 KB, text/plain)
2002-09-01 13:10 EDT, Vasco Alexandre da Silva Costa
no flags Details
lspci -vv (pciutils-2.1.8-23 from RH 7.2) with pci.ids snapshot from 2002-09-01 10:00:05 (8.97 KB, text/plain)
2002-09-01 13:44 EDT, Vasco Alexandre da Silva Costa
no flags Details

  None (edit)
Description Vasco Alexandre da Silva Costa 2002-08-26 18:39:01 EDT
Description of Problem:

I get a black screen when running X11 anaconda on install.

I guess the problem is either X11 related or in your hardware auto-detection 
code.

I have an MSI nForce motherboard and a Samsung SyncMaster 957DF monitor. I am 
using the onboard NVIDIA motherboard graphics. nForce is allegedly supported 
by XFree86 4.2 (or so it says here: 
http://www.xfree86.org/4.2.0/RELNOTES2.html#2).

How Reproducible:

Just press <ENTER> to select the default graphic install, and keep going until 
anaconda starts up.
It detects the on-board nForce graphics as a GeForce 2 MX (generic) which is 
pretty much accurate I guess, fails to detect my  monitor, and detects my 
mouse more or less ok.

X then starts up (to run anaconda I guess) and I get a pretty black screen. No 
amount of waiting of keypressing changes things.

I could use the text mode install (double yuck). If you can't fix the issue 
with X, at least allow us to select the standard vga or vesa driver on 
startup. i.e. 'linux vesa' or 'linux vga'.

Actual Results:

A black screen.

Expected Results:

Well... how about anaconda displaying its stuff on my screen? :-)

Additional Information:
	
OT: Having to register an account to do a bug report is sick.
Comment 1 Michael Fulbright 2002-08-27 01:09:27 EDT
Appears to be an XFree86 issue.

Mike does kudzu not have the correct PCI ids for the nvidia stuff?
Comment 2 Mike A. Harris 2002-09-01 06:36:17 EDT
Please attach the output of:  lspci -vvn  and lspci -vv
Comment 3 Vasco Alexandre da Silva Costa 2002-09-01 13:10:15 EDT
Created attachment 74427 [details]
lspci -vvn
Comment 4 Vasco Alexandre da Silva Costa 2002-09-01 13:10:42 EDT
Created attachment 74428 [details]
lspci -vv
Comment 5 Vasco Alexandre da Silva Costa 2002-09-01 13:14:51 EDT
NOTE: The lspci command was run with stock RedHat 7.2 + kernel 2.4.19.
Comment 6 Vasco Alexandre da Silva Costa 2002-09-01 13:44:15 EDT
Created attachment 74429 [details]
lspci -vv (pciutils-2.1.8-23 from RH 7.2) with pci.ids snapshot from 2002-09-01 10:00:05
Comment 7 Vasco Alexandre da Silva Costa 2002-11-01 06:45:42 EST
Please see this thread in the Xpert mailing-list:

http://www.xfree86.org/pipermail/xpert/2002-October/021086.html

It is the same problem I had.

What worked for him worked for me too:

http://www.xfree86.org/pipermail/xpert/2002-October/021155.html

I guess you need to build some new RPMs...
Comment 8 Mike A. Harris 2002-12-21 06:20:15 EST
The XFree86 archives you refer to above, are not available.

nForce graphics are not supported in Red Hat Linux 8.0, however, rawhide
XFree86 does support nForce now I believe.  Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.