Bug 727226 - Request: Update to Netatalk 2.2.0
Summary: Request: Update to Netatalk 2.2.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: netatalk
Version: el6
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Jiri Skala
QA Contact: Fedora Extras Quality Assurance
URL: http://netatalk.sourceforge.net/2.2/R...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-01 15:26 UTC by Greg Smith
Modified: 2014-11-09 22:34 UTC (History)
3 users (show)

Fixed In Version: netatalk-2.2.0-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-19 20:11:52 UTC
Type: ---


Attachments (Terms of Use)

Description Greg Smith 2011-08-01 15:26:23 UTC
Description of problem:

This bug report is being created as a request to update Netatalk from 2.1.5 to 2.2.0 in the EPEL repository.

The latest version of Mac OS X Lion (10.7) will no longer run Timemachine backups to a AFP server that does not support the latest protocols.  It seems this was done for security reasons, but the ability to run Timemachine backups is one of the more common use cases for still installing Netatalk on server systems.

Netatalk 2.2.0 recently went from Beta to full stable release.  It would be great if the package in EPEL could be updated, so users of the repo could update without recompiling themselves.

Version-Release number of selected component (if applicable):

Netatalk 2.1.5 is currently available in the repo.  This request is to update the repo version to 2.2.0


How reproducible:

The reason for the update is to allow compatibility with Mac OS X Lion (10.7)  Mac 10.7 will not connect to a 2.1.5 Netatalk server.

Comment 1 Greg Smith 2011-08-01 15:38:22 UTC
Added URL to Netatalk 2.2.0 release notes, which include details on requirements of OS X Lion (10.7) and Timemachine.

Comment 2 Fedora Update System 2011-08-02 07:34:50 UTC
netatalk-2.2.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/netatalk-2.2.0-1.el6

Comment 3 Fedora Update System 2011-08-02 20:24:55 UTC
Package netatalk-2.2.0-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing netatalk-2.2.0-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/netatalk-2.2.0-1.el6
then log in and leave karma (feedback).

Comment 4 Greg Smith 2011-08-03 01:20:10 UTC
Tried it out today, and it worked, no problems.  Left a comment on the fedoraproject.org page.

Here's the comment I left:

Tried this out today, and it worked great. I am running Timemachine backup to it now. The only surprise was that the directory for configuration changed from /etc/atalk to /etc/netatalk . This makes more sense, but does require merging all changes over to the new files after installing.

Comment 5 Fedora Update System 2011-08-19 20:11:47 UTC
netatalk-2.2.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Adam Huffman 2011-11-25 12:12:19 UTC
Would you consider an update for the EPEL 5 branch, too?


Note You need to log in before you can comment on or make changes to this bug.