Bug 727280 - Request to recompile libraries with -Wl,-z,relro flags
Summary: Request to recompile libraries with -Wl,-z,relro flags
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: keyutils   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: David Howells
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 727296 RHEL62CCC 846801 846802
TreeView+ depends on / blocked
 
Reported: 2011-08-01 17:59 UTC by Irina Boverman
Modified: 2012-12-06 18:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 833316 (view as bug list)
Environment:
Last Closed: 2011-12-06 17:01:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1684 normal SHIPPED_LIVE keyutils bug fix and enhancement update 2011-12-06 00:50:03 UTC

Comment 2 RHEL Product and Program Management 2011-08-01 18:29:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 David Howells 2011-08-02 15:14:09 UTC
Shouldn't this be handled by rpmbuild's default flags?

Comment 4 Steve Grubb 2011-08-02 15:21:25 UTC
On Fedora 16 and later yes. It manual for RHEL4/5/6.

Comment 7 errata-xmlrpc 2011-12-06 17:01:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1684.html


Note You need to log in before you can comment on or make changes to this bug.