Bug 727335 - openssh-5.6p1-33.fc15.1.x86_64 uses deprecated /proc/<pid>/oom_adj
openssh-5.6p1-33.fc15.1.x86_64 uses deprecated /proc/<pid>/oom_adj
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
15
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
: 720749 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-01 16:37 EDT by Alessandro Suardi
Modified: 2011-08-04 23:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: openssh-5.6p1-34.fc15.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-04 23:52:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessandro Suardi 2011-08-01 16:37:11 EDT
Description of problem:

booting F15 causes a WARNING to be printed since kernel.org 3.0.0-git7
 due to usage of a deprecated interface by sshd.

Version-Release number of selected component (if applicable):

openssh-5.6p1-33.fc15.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1. build a 3.0.0-git7 or later kernel in F15
2. boot said kernel
3. observe a WARNING being printed about sshd

Actual results:

In 3.0.0-git14 I have:

------------[ cut here ]------------
WARNING: at fs/proc/base.c:1123 oom_adjust_write+0x185/0x23c()
Hardware name: Latitude E6400                  
sshd (3191): /proc/3191/oom_adj is deprecated, please use /proc/3191/oom_score_adj instead.
Modules linked in: ipt_REJECT rfcomm nf_conntrack_ipv4 nf_defrag_ipv4 bnep xt_state nf_conntrack ip6table_filter ip6_tables iptable_filter ip_tables snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep aes_x86_64 aes_generic snd_seq snd_seq_device ecb dell_laptop snd_pcm btusb bluetooth snd_timer snd rfkill pcspkr soundcore i2c_i801 snd_page_alloc joydev microcode dcdbas ipv6 autofs4 ext4 jbd2 crc16 sdhci_pci sdhci firewire_ohci firewire_core crc_itu_t mmc_core i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
Pid: 3191, comm: sshd Not tainted 3.0.0-git14 #1
Call Trace:
 [<ffffffff81037648>] warn_slowpath_common+0x7e/0x96
 [<ffffffff810376f4>] warn_slowpath_fmt+0x41/0x43
 [<ffffffff810407f8>] ? ns_capable+0x35/0x4a
 [<ffffffff8112a0b8>] oom_adjust_write+0x185/0x23c
 [<ffffffff810e08c6>] vfs_write+0xa3/0xca
 [<ffffffff81091583>] ? trace_hardirqs_on_caller+0xe/0x22
 [<ffffffff810e0a62>] sys_write+0x45/0x69
 [<ffffffff813753bb>] system_call_fastpath+0x16/0x1b
---[ end trace 6e217f391cb03650 ]---

Expected results:

No WARNING printed.

Additional info:

This seems to be fixed in openssh 5.7p1

https://bugzilla.mindrot.org/show_bug.cgi?id=1838
Comment 1 Jan F. Chadima 2011-08-02 05:01:30 EDT
*** Bug 720749 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2011-08-03 06:42:45 EDT
openssh-5.6p1-34.fc15.1 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/openssh-5.6p1-34.fc15.1
Comment 3 Alessandro Suardi 2011-08-03 08:18:37 EDT
I tested the koji packages for 5.6p1-34 and the WARNING disappeared.

Feel free to close the bug at your discretion. Thanks !
Comment 4 Fedora Update System 2011-08-03 18:55:11 EDT
Package openssh-5.6p1-34.fc15.1:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openssh-5.6p1-34.fc15.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openssh-5.6p1-34.fc15.1
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-08-04 23:52:24 EDT
openssh-5.6p1-34.fc15.1 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.