This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 72736 - fonts.dir created with wrong permissions
fonts.dir created with wrong permissions
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 01:13 EDT by Steve Fox
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 05:56:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2002-08-27 01:13:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
After installing XFree86-base-fonts-4.2.0-67, X refused to restart because xfs
was dying. After tail'ing /var/log/messages, I found it was having issues
reading the /usr/X11R6/lib/X11/fonts/misc fonts. So I checked the perms on
fonts.dir and it was set 600. I changed it to 644, restarted xfs, and things are
working again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install XFree86-base-fonts-4.2.0-67 
2. Restart X

Additional info:
Comment 1 Mike A. Harris 2002-08-27 05:56:13 EDT
I can't reproduce this and cant see how it is possible for this
to happen.   I have patched mkfontdir ages ago so that it will
only ever write out fonts.dir, encodings.dir mode 0666

It's been this way since before RHL 7.3.  If you are using
rawhide packages on a Red hat Linux 7.[012] system, and are
using an older mkfontdir, this would potentially explain it.

Can you reproduce this on a fresh install of Null beta?

XFree86-4.1.99.2-mkfontdir-perms.patch

--- xc/programs/mkfontdir/mkfontdir.c.mkfontdir-perms   Mon Aug 20 10:00:57 2001
+++ xc/programs/mkfontdir/mkfontdir.c   Fri Nov  2 00:52:14 2001
@@ -204,6 +204,7 @@
    fprintf (file, "%s %s\n", entry->u.bitmap.fileName, entry->name.name);
     }
     fclose (file);
+    chmod(file, 0644);
 
     return TRUE;
 }
@@ -235,6 +236,7 @@
         fprintf(file, "%s %s%s\n",
                 encoding->name, prefix, encoding->fileName);
     fclose(file);
+    chmod(file, 0644);
 
     return TRUE;
 }



Comment 2 Steve Fox 2002-08-27 10:15:23 EDT
Well, I'm stumped because it didn't happen this time. I don't believe I ever
touched the misc directory before.  I reinstalled (null) and then upgraded the
XFree86* packages from rawhide. I guess things are ok now. Sorry for the bother.

Note You need to log in before you can comment on or make changes to this bug.