Bug 727381 - installation stops at "Examining storage devices"
installation stops at "Examining storage devices"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
i386 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: udev-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-01 20:55 EDT by Felix Miata
Modified: 2011-10-21 05:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 05:39:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-tb-* logs (133.27 KB, application/octet-stream)
2011-08-01 20:55 EDT, Felix Miata
no flags Details

  None (edit)
Description Felix Miata 2011-08-01 20:55:50 EDT
Created attachment 516232 [details]
anaconda-tb-* logs

Description of problem:
"Examining storage devices"

Version-Release number of selected component (if applicable):
Anaconda 16.13

Steps to Reproduce:
1.Download F16 installation vmlinuz & initrd.img from mirror containing 20110721/i386/os/isolinux
2.Load them from PATA on ICH4 containing 1G RAM, 1G swap, 31 total partitions using Legacy Grub thus:
title Install Fedora 16 devel (to hd0,17) from mirrors.us.kernel.org
    kernel (hd0,4)/rawhide/vmlinuz showopts repo=http://mirrors.us.kernel.org/fedora/development/16/i386/os dns=207.69.188.187,207.69.188.186 gateway=192.168.1.1 graphical ip=192.168.1.2 netmask=255.255.255.0 hostname=myhost.domain selinux=0 noipv6 resolution=1024x768 video=1152x864 xdriver=intel 
    initrd (hd0,4)/rawhide/initrd.img
  
Actual results:
installation stops at "Examining storage devices"

Expected results:
installation proceeds at least past partitioning

Additional info:
I left it stalled with that message more than 30 minutes before saving the logs and rebooting. PATA target only accessible storage device (empty floppy drive, CDRW/DVD drive containing upside down media, no USB, Firewire or eSATA storage devices, no PXE).
Comment 1 Chris Lumens 2011-08-02 09:05:58 EDT
It looks like you're caught in a loop waiting for the udev event queue to be empty:

20:16:56,132 INFO program: udevadm settle - timeout of 300 seconds reached, the event queue contains:
20:16:56,134 INFO program:   /sys/devices/virtual/vc/vcs5 (1600)
20:16:56,137 INFO program:   /sys/devices/virtual/vc/vcs5 (1959)
20:16:56,155 INFO program: Running... udevadm settle --timeout=300

(1) I don't know why we don't just give up.
(2) I don't know why those are still stuck in the queue.
Comment 2 Vasile Chelban 2011-09-25 06:20:25 EDT
While I encountered this bug during install of Fedora 16 Aplha, it seems to be fixed in Fedora 16 Beta RC2. Successfully installed on two different systems that has showed behavior described above.
Comment 3 Fedora Admin XMLRPC Client 2011-10-20 12:08:04 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-10-20 12:10:04 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-10-20 12:12:30 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-10-20 12:16:58 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.