Bug 727401 - repoclosure failure in 16-Alpha.TC1 DVDs
repoclosure failure in 16-Alpha.TC1 DVDs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
AcceptedBlocker
:
Depends On:
Blocks: F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-08-01 23:31 EDT by Andre Robatino
Modified: 2014-03-16 23:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: vinagre-3.1.4-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-06 00:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2011-08-01 23:31:37 EDT
Description of problem:
On i386:

Added myrepo repo from /media
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   myrepo
Num Packages in Repos: 3026
package: 1:cheese-3.0.2-1.fc16.i686 from myrepo
  unresolved deps: 
     libcogl.so.1
package: 1:cheese-libs-3.0.2-1.fc16.i686 from myrepo
  unresolved deps: 
     libcogl.so.1
package: 9:kdevelop-libs-4.2.3-3.fc16.i686 from myrepo
  unresolved deps: 
     okteta >= 0:4.6.95
package: clutter-gtk-1.0.2-1.fc16.i686 from myrepo
  unresolved deps: 
     libcogl.so.1
package: empathy-3.1.3-4.fc16.i686 from myrepo
  unresolved deps: 
     libcogl.so.1
package: gnome-shell-3.1.3-2.fc16.i686 from myrepo
  unresolved deps: 
     libcogl.so.1
package: mutter-3.1.3.1-2.fc16.i686 from myrepo
  unresolved deps: 
     libcogl.so.1
package: sushi-0.0.4-1.fc16.i686 from myrepo
  unresolved deps: 
     libcogl.so.1
package: tracker-0.10.10-1.fc16.i686 from myrepo
  unresolved deps: 
     libpoppler-glib.so.6
     libpoppler.so.13
package: vinagre-3.1.4-1.fc16.i686 from myrepo
  unresolved deps: 
     libspice-client-glib-2.0.so.4
     libspice-client-glib-2.0.so.4(SPICEGTK_1)
package: virt-viewer-0.4.0-1.fc16.i686 from myrepo
  unresolved deps: 
     libspice-client-glib-2.0.so.3
     libspice-client-glib-2.0.so.3(SPICEGTK_1)

On x86_64:

Added myrepo repo from /media
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   myrepo
Num Packages in Repos: 3020
package: 1:cheese-3.0.2-1.fc16.x86_64 from myrepo
  unresolved deps: 
     libcogl.so.1()(64bit)
package: 1:cheese-libs-3.0.2-1.fc16.x86_64 from myrepo
  unresolved deps: 
     libcogl.so.1()(64bit)
package: 9:kdevelop-libs-4.2.3-3.fc16.x86_64 from myrepo
  unresolved deps: 
     okteta >= 0:4.6.95
package: clutter-gtk-1.0.2-1.fc16.x86_64 from myrepo
  unresolved deps: 
     libcogl.so.1()(64bit)
package: empathy-3.1.3-4.fc16.x86_64 from myrepo
  unresolved deps: 
     libcogl.so.1()(64bit)
package: gnome-shell-3.1.3-2.fc16.x86_64 from myrepo
  unresolved deps: 
     libcogl.so.1()(64bit)
package: mutter-3.1.3.1-2.fc16.x86_64 from myrepo
  unresolved deps: 
     libcogl.so.1()(64bit)
package: sushi-0.0.4-1.fc16.x86_64 from myrepo
  unresolved deps: 
     libcogl.so.1()(64bit)
package: tracker-0.10.10-1.fc16.x86_64 from myrepo
  unresolved deps: 
     libpoppler-glib.so.6()(64bit)
     libpoppler.so.13()(64bit)
package: vinagre-3.1.4-1.fc16.x86_64 from myrepo
  unresolved deps: 
     libspice-client-glib-2.0.so.4(SPICEGTK_1)(64bit)
     libspice-client-glib-2.0.so.4()(64bit)
package: virt-viewer-0.4.0-1.fc16.x86_64 from myrepo
  unresolved deps: 
     libspice-client-glib-2.0.so.3(SPICEGTK_1)(64bit)
     libspice-client-glib-2.0.so.3()(64bit)

Version-Release number of selected component (if applicable):
16-Alpha.TC1 DVDs
Comment 1 Hongqing Yang 2011-08-02 01:52:21 EDT
package: 1:cheese-3.0.2-1.fc16.i686 from iso_repo_1
  unresolved deps: 
     libcogl.so.1
package: 1:cheese-libs-3.0.2-1.fc16.i686 from iso_repo_1
  unresolved deps: 
     libcogl.so.1
package: 9:kdevelop-libs-4.2.3-3.fc16.i686 from iso_repo_1
  unresolved deps: 
     okteta >= 0:4.6.95
package: clutter-gtk-1.0.2-1.fc16.i686 from iso_repo_1
  unresolved deps: 
     libcogl.so.1
package: empathy-3.1.3-4.fc16.i686 from iso_repo_1
  unresolved deps: 
     libcogl.so.1
package: gnome-shell-3.1.3-2.fc16.i686 from iso_repo_1
  unresolved deps: 
     libcogl.so.1
package: mutter-3.1.3.1-2.fc16.i686 from iso_repo_1
  unresolved deps: 
     libcogl.so.1
package: sushi-0.0.4-1.fc16.i686 from iso_repo_1
  unresolved deps: 
     libcogl.so.1
package: tracker-0.10.10-1.fc16.i686 from iso_repo_1
  unresolved deps: 
     libpoppler-glib.so.6
     libpoppler.so.13
package: vinagre-3.1.4-1.fc16.i686 from iso_repo_1
  unresolved deps: 
     libspice-client-glib-2.0.so.4
     libspice-client-glib-2.0.so.4(SPICEGTK_1)
package: virt-viewer-0.4.0-1.fc16.i686 from iso_repo_1
  unresolved deps: 
     libspice-client-glib-2.0.so.3
     libspice-client-glib-2.0.so.3(SPICEGTK_1)
Comment 3 Adam Williamson 2011-08-03 21:24:32 EDT
that solves the cogl deps. It does not solve the libpoppler or libspice deps.

There is no tracker build that fixes the tracker / libpoppler issue: deji has tried to build a newer tracker several times, but failed each time. http://koji.fedoraproject.org/koji/buildinfo?buildID=255658 is the latest attempt. I'll see if I can fix it up.

There is no updated vinagre build that I can find. We should request one from desktop team, or just do it (I'll see if I can do that).

https://admin.fedoraproject.org/updates/virt-viewer-0.4.0-2.fc16 should fix the virt-viewer / libspice issue.
Comment 4 Fedora Update System 2011-08-03 22:10:55 EDT
tracker-0.10.21-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tracker-0.10.21-1.fc16
Comment 5 Fedora Update System 2011-08-03 22:27:10 EDT
vinagre-3.1.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/vinagre-3.1.4-2.fc16
Comment 7 Fedora Update System 2011-08-04 17:12:53 EDT
Package vinagre-3.1.4-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vinagre-3.1.4-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/vinagre-3.1.4-2.fc16
then log in and leave karma (feedback).
Comment 8 Tim Flink 2011-08-05 16:54:17 EDT
Discussed in the 2011-08-05 blocker review meeting. Accepted as a Fedora 16 alpha blocker as it violates the following alpha release criterion [1]:

There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 9 Fedora Update System 2011-08-06 00:25:22 EDT
vinagre-3.1.4-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-08-06 00:25:47 EDT
tracker-0.10.21-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.