This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 727501 - [regression] Changes to ifcfg files are not handled properly
[regression] Changes to ifcfg files are not handled properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
15
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 723475 (view as bug list)
Depends On:
Blocks: F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-08-02 06:17 EDT by Jirka Klimes
Modified: 2016-01-04 01:02 EST (History)
7 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 23:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jirka Klimes 2011-08-02 06:17:06 EDT
Description of problem:

When ONBOOT is changed from "no" to "yes", the connection is not auto-activated.
Also, changes of NM_CONTROLLED to "yes" only works the first time, but subsequent changes have no effect.

How reproducible:
Always

Steps to Reproduce:
1. Change ONBOOT from "no" to "yes" while no connection is active
2. The connection should auto-activate, but it doesn't

1. Change NM_CONTROLLED "no" -> "yes", "yes" -> "no", "no" -> "yes"
2. The third change has no effect
Comment 1 Jirka Klimes 2011-08-02 06:26:48 EDT
Fixed upstream in master by commits:
312c7c952cbb3f20bcb1092db9bfbb51485fcebd
adc7ec170d429b6b8cdeb302c8afa96fbd3ba907
Comment 2 Tim Flink 2011-08-04 15:29:53 EDT
I'm not sure this qualifies as an alpha blocker. If I'm missing something, can you point out which alpha release criterion [1] this bug violates?

[1] http://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 3 Tim Flink 2011-08-04 15:33:38 EDT
After looking at another bug, I'm wondering if this is the same issue as bug 723475.

If so, let's close it out as a dupe.
Comment 4 Tim Flink 2011-08-04 15:38:42 EDT
Alright, I need to start reading ALL the fields before commenting. Ignore my last two comments - apologies for the spam.

Since this bug interferes with network connectivity in anaconda, it appears to violate the following fedora 16 alpha release criteria:

The installer must be able to report failures to Bugzilla, with appropriate
information included

Has the code in the commit mentioned in comment #1 been pushed to testing or stable?
Comment 5 Adam Williamson 2011-08-04 22:56:53 EDT
Jirka, Dan - can one of you please do an F16 build with these patches and submit it as an update? this is an Alpha blocker bug so it is preventing us doing an RC compose, which was due today. Thanks!
Comment 6 Tim Flink 2011-08-05 13:18:00 EDT
Discussed in the 2011-08 blocker review meeting. Accepted as a Fedora 16 alpha blocker as it violates the following alpha release criterion [1]:

The installer must be able to report failures to Bugzilla, with appropriate information included

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 7 Fedora Update System 2011-08-05 16:21:06 EDT
NetworkManager-0.8.9997-7.git20110721.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.9997-7.git20110721.fc16
Comment 8 Tim Flink 2011-08-05 16:52:32 EDT
*** Bug 723475 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2011-08-06 00:27:01 EDT
Package NetworkManager-0.8.9997-7.git20110721.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.9997-7.git20110721.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.9997-7.git20110721.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-08-08 23:27:04 EDT
NetworkManager-0.8.9997-7.git20110721.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-08-26 15:25:47 EDT
NetworkManager-0.9.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.0-1.fc15
Comment 12 Fedora Update System 2011-09-10 20:00:07 EDT
NetworkManager-0.9.0-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.