Bug 727513 - [abrt] smolt-1.4.3-3.fc15: devicelist.py:76:cat:IOError: [Errno 2] No such file or directory: '/sys/devices/virtual/dmi/id/sys_vendor'
[abrt] smolt-1.4.3-3.fc15: devicelist.py:76:cat:IOError: [Errno 2] No such fi...
Status: CLOSED DUPLICATE of bug 727518
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
abrt_hash:07b35a3958eb147ad75cb06d5e3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-02 06:49 EDT by Mads Kiilerich
Modified: 2011-11-05 14:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-12 13:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2011-08-02 06:49:48 EDT
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/bin/smoltSendProfile -p
comment:        Seen when running f15 32-bit on an Imac in EFI mode
component:      smolt
executable:     /usr/bin/smoltSendProfile
global_uuid:    07b35a3958eb147ad75cb06d5e3a94784e0f06be
kernel:         2.6.38.6-26.rc1.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        smolt-1.4.3-3.fc15
reason:         devicelist.py:76:cat:IOError: [Errno 2] No such file or directory: '/sys/devices/virtual/dmi/id/sys_vendor'
time:           Tue Aug  2 11:36:21 2011
uid:            0
username:       root

backtrace:
:devicelist.py:76:cat:IOError: [Errno 2] No such file or directory: '/sys/devices/virtual/dmi/id/sys_vendor'
:
:Traceback (most recent call last):
:  File "/usr/bin/smoltSendProfile", line 152, in <module>
:    profile = smolt.get_profile()
:  File "/usr/share/smolt/client/smolt.py", line 1415, in get_profile
:    return Hardware()
:  File "/usr/share/smolt/client/smolt.py", line 1004, in Hardware
:    _hardware_instance = _Hardware()
:  File "/usr/share/smolt/client/smolt.py", line 591, in __init__
:    self.host = Host()
:  File "/usr/share/smolt/client/smolt.py", line 306, in __init__
:    self.systemVendor = cat('/sys/devices/virtual/dmi/id/sys_vendor')[0].strip()
:  File "/usr/share/smolt/client/devicelist.py", line 76, in cat
:    fd = open(file, 'r')
:IOError: [Errno 2] No such file or directory: '/sys/devices/virtual/dmi/id/sys_vendor'
:
:Local variables in innermost frame:
:file: '/sys/devices/virtual/dmi/id/sys_vendor'
Comment 1 Mads Kiilerich 2011-08-12 13:25:55 EDT
Not a direct duplicate of bug 727518 but closely related.

*** This bug has been marked as a duplicate of bug 727518 ***

Note You need to log in before you can comment on or make changes to this bug.