Bug 727514 - Package Verne theming/branding for KDE
Package Verne theming/branding for KDE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
RejectedBlocker, AcceptedNTH
:
Depends On:
Blocks: F16Alpha-accepted/F16AlphaFreezeExcept F16Blocker-kde
  Show dependency treegraph
 
Reported: 2011-08-02 06:54 EDT by Jaroslav Reznik
Modified: 2011-08-06 00:26 EDT (History)
9 users (show)

See Also:
Fixed In Version: verne-kde-theme-15.91.0-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-06 00:26:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2011-08-02 06:54:40 EDT
Description of problem: create and package Verne theming/branding for KDE.


Version-Release number of selected component (if applicable):
Fedora 16 alpha

Steps to Reproduce:
1. boot to KDE
  
Actual results:
Lovelock theming

Expected results:
Verne theming

Additional info:
Target release Fedora 16 alpha
Comment 1 Fedora Update System 2011-08-02 07:47:59 EDT
lovelock-kde-theme-14.90.1-2.fc16,verne-kde-theme-15.91.0-1.fc16,kde-settings-4.7-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lovelock-kde-theme-14.90.1-2.fc16,verne-kde-theme-15.91.0-1.fc16,kde-settings-4.7-3.fc16
Comment 2 Kevin Kofler 2011-08-03 21:31:45 EDT
We really want this one in the Alpha.
Comment 3 Adam Williamson 2011-08-03 21:47:30 EDT
If any of the 'old' artwork specifically mentions 'Fedora 15' or 'Lovelock', then that would constitute an infringement of criterion "The default Fedora artwork must either refer to the current Fedora release under development (Fedora 16), or reference an interim release milestone (e.g. Alpha or Beta). If a release version number is used, it must match the current Fedora release under development. This includes artwork used in the installer, graphical bootloader menu, firstboot, graphical boot, graphical login and desktop background.", and I'd vote +1 for blocker. If not, this is probably NTH rather than blocker (which still means we'd pull it in). Can you specify which case applies? Thanks!
Comment 4 Kevin Kofler 2011-08-03 21:51:35 EDT
"Lovelock" shows up in the theme names in the settings dialogs, at least.

But the imagery doesn't really refer to Lovelock explicitly, and there are no version numbers in Fedora artwork (except for some Anaconda images) by design.
Comment 5 Tim Flink 2011-08-04 16:36:14 EDT
If the desktop background is still from F15, that would still count as a blocker by my reading of the criterion.

If that is the case, I'm +1 alpha blocker on this
Comment 6 Kevin Kofler 2011-08-04 17:49:29 EDT
That is indeed the case.
Comment 7 Adam Williamson 2011-08-04 19:57:48 EDT
it's not by my reading: the emphasis on numbers in the criterion is intentional, because it exists for a specific practical reason. We found that people would get worried and confused when installing a pre-release if it referred to the 'wrong' version number. Including the 'wrong' wallpaper isn't going to worry or confuse anyone - if you're Fedora-savvy enough to know which wallpapers relate to which releases, you're probably not going to be too worried about an old one getting into a pre-release.

but it's a bit academic, as we'll take the fix anyway.
Comment 8 Tim Flink 2011-08-05 14:12:30 EDT
Discussed in the 2011-08-05 blocker review meeting. Accepted as a Fedora 16 NTH [1] bug as it doesn't hit any of the alpha release criteria [2] but it would be nice to have this resolved before Alpha.


[1] http://fedoraproject.org/wiki/QA:SOP_nth_bug_process
[2] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 9 Kevin Kofler 2011-08-05 16:49:33 EDT
OK. This is already queued for stable, can it please get pulled in?
Comment 10 Fedora Update System 2011-08-06 00:26:20 EDT
verne-kde-theme-15.91.0-1.fc16, kde-settings-4.7-3.fc16, lovelock-kde-theme-14.91.0-2.fc16 has been pushed to the Fedora 16 stable repository.

Note You need to log in before you can comment on or make changes to this bug.