Bug 727525 - [JUNIPER] System locks up randomly when opening/closing/resizing windows after recent update to Fedora 15
Summary: [JUNIPER] System locks up randomly when opening/closing/resizing windows afte...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: [cat:lockup]
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 11:35 UTC by Greg
Modified: 2012-08-07 16:31 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 712533
Environment:
Last Closed: 2012-08-07 16:31:30 UTC


Attachments (Terms of Use)
output of dmesg command (94.45 KB, text/plain)
2011-08-02 11:35 UTC, Greg
no flags Details
messages (330.06 KB, text/plain)
2011-08-02 11:36 UTC, Greg
no flags Details
xorg.*.log (100.05 KB, text/plain)
2011-08-02 11:36 UTC, Greg
no flags Details

Description Greg 2011-08-02 11:35:39 UTC
Created attachment 516303 [details]
output of dmesg command

we have same problem to the one quoted below with one of our machines. The system locks up unexpectedly.
I have attached the information requested in the orginal report:

Kernel version:
2.6.38.8-35.fc15.x86_64

Xorg version:
X.Org X Server 1.6.3.901 (1.6.4 RC 1)
Release Date: 2009-8-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-164.el5 x86_64 
Current Operating System: Linux pedigree.local 2.6.30.10-105.2.23.fc11.x86_64 #1 SMP Thu Feb 11 07:06:34 UTC 2010 x86_64
Kernel command line: ro root=/dev/mapper/vg_pedigree-lv_root rhgb quiet
Build Date: 09 September 2009  11:26:05AM
Build ID: xorg-x11-server 1.6.4-0.1.fc11 


+++ This bug was initially created as a clone of Bug #712533 +++

Description of problem:
I'm having these system lock ups since the kernel update if my memory doesn't betray me. It doesn't always happen, just randomly once in a while while doing things with windows (nothing happened yet when just dragging them around). Audio playback stops, I can't move the mouse pointer and pressing the reset button once doesn't work, I have to hold it for a while so that the system forcibly powers off and back on again. 

Version-Release number of selected component (if applicable):
(Fully updated F15 system as of the time of this writing)
kernel-2.6.38.7-30.fc15.x86_64
xorg-x11-drv-ati-6.14.1-1.20110504gita6d2dba6.fc15.x86_64
libdrm-2.4.26-1.fc15.x86_64
mesa-dri-drivers-7.11-0.11.20110525.0.fc15.x86_64
mesa-dri-filesystem-7.11-0.11.20110525.0.fc15.x86_64
mesa-dri-llvmcore-7.11-0.11.20110525.0.fc15.x86_64
mesa-libGL-7.11-0.11.20110525.0.fc15.i686
mesa-libGL-7.11-0.11.20110525.0.fc15.x86_64
mesa-libGL-devel-7.11-0.11.20110525.0.fc15.x86_64
mesa-libGLU-7.11-0.11.20110525.0.fc15.i686
mesa-libGLU-7.11-0.11.20110525.0.fc15.x86_64
mesa-libGLU-devel-7.11-0.11.20110525.0.fc15.x86_64

Steps to Reproduce:
1. Open/close/resize windows repeatedly.
  
Actual results:
System locks up eventually.

Expected results:
No lock up.

Additional info:
My System is a Core i5-2500 on an Intel DH67CL (BIOS version 5/23/2011), 8GB of RAM with a Radeon 5870 (/sys/class/drm/card0/device/power_profile is set to auto, hovers at about 50°C)

--- Additional comment from madigens@gmail.com on 2011-06-10 17:44:52 EDT ---

Ugh, I was using kernel-2.6.38.6-27.fc15.x86_64 when writing the bug report, where I previously had no lock ups. After submitting the bug and clicking on "Bug 712533" at the top, the system froze again... so now I'm not sure if I categorized the bug report right. At first I thought this was related to the radeon-updates shipped with the newest kernel, but maybe it's something else. Sorry if this is noise :(

--- Additional comment from el.il@doom.co.il on 2011-06-11 03:07:13 EDT ---

Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from madigens@gmail.com on 2011-06-11 19:03:52 EDT ---

Created attachment 504277 [details]
dmesg

--- Additional comment from madigens@gmail.com on 2011-06-11 19:04:31 EDT ---

Created attachment 504278 [details]
/var/log/messages, shortened

--- Additional comment from madigens@gmail.com on 2011-06-11 19:05:00 EDT ---

Created attachment 504279 [details]
Xorg.0.log

--- Additional comment from madigens@gmail.com on 2011-06-11 19:06:22 EDT ---

Comment on attachment 504279 [details]
Xorg.0.log

(side note: Xorg seems to configure my USB Audio DAC as a keyboard :D)

--- Additional comment from madigens@gmail.com on 2011-06-11 19:08:43 EDT ---

Created attachment 504281 [details]
The only xorg.conf file I have, in xorg.conf.d

--- Additional comment from madigens@gmail.com on 2011-06-11 19:11:53 EDT ---

Comment on attachment 504278 [details]
/var/log/messages, shortened

fixed wrong mime type

--- Additional comment from madigens@gmail.com on 2011-06-17 18:51:51 EDT ---

Happened again with kernel-2.6.38.8-32.fc15.x86_64, this time while switching virtual desktops in Gnome 3.

--- Additional comment from madigens@gmail.com on 2011-06-23 11:54:49 EDT ---

What can I do to help getting this fixed faster?

--- Additional comment from jglisse@redhat.com on 2011-06-23 13:15:24 EDT ---

Lockup are not easy to fix, just update regulary, there have been some change lately that might help in this area.

There is no debug instruction that one can follow.

--- Additional comment from madigens@gmail.com on 2011-07-03 11:48:02 EDT ---

Still happens with xorg-x11-drv-ati-6.14.1-2.20110525gitfe5c42f51.fc15.x86_64.

--- Additional comment from el.il@doom.co.il on 2011-07-03 11:54:51 EDT ---

Moving back to xorg-x11-drv-ati, I have no idea why you've moved it to the completely unrelated component 0xFFFF.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from madigens@gmail.com on 2011-07-14 10:07:59 EDT ---

Me? Didn't move anything, at least not knowingly.

Still happens with kernel-2.6.38.8-35.fc15.x86_64.

--- Additional comment from madigens@gmail.com on 2011-07-14 14:01:03 EDT ---

And it still happens with mesa-*-7.11-0.16.20110709.0.fc15.x86_64 from updates-testing.

--- Additional comment from lestertron@gmail.com on 2011-07-18 05:20:33 EDT ---

I've recently installed Fedora 15 on my Mac Pro with ATI 5870 and it appears I'm hitting the same bug.  It's a real show stopper as otherwise everything is great.

madigens: Are you saying that this *didn't* happen for you with a certain kernel and driver version?  If so which versions?

FYI I'm using:

Kernel 2.6.38.8-35.fc15.x86_64
xorg-x11-drv-ati-6.14.1-2.20110525gitfe5c42f51.fc15.x86_64

I'm a bit concerned with the log files, there seems to be nothing useful related to the lock-up. Mine show pretty much the same stuff relating to madigens entries.  Happy to attach mine as well if it might help....

--- Additional comment from madigens@gmail.com on 2011-07-18 19:03:12 EDT ---

@Lester Wade: Yes, 2.6.38.6-27.fc15.x86_64 worked great and still does, because that's what I'm still running :) Would love to run the newest one, but this bug really is a show-stopper. only experienced 1 or maybe 2 lockups with this one. 38.7 and upwards all lock up randomly. Updating xorg-x11-drv-ati or mesa didn't help. So either it's a bug in the radeon patchset introduced in .7 or or the patchset is fine and exposes a bug in some other component.

By the way, I got a Netbook sitting here. Is there a way to redirect the logging from this PC to the Netbook via USB or something? Maybe something turns up just before the hang...

Comment 1 Greg 2011-08-02 11:36:11 UTC
Created attachment 516304 [details]
messages

Comment 2 Greg 2011-08-02 11:36:45 UTC
Created attachment 516305 [details]
xorg.*.log

Comment 3 Nikolaus Waxweiler 2011-10-06 13:35:36 UTC
No idea why this bug was copied for Juniper, but on my Cypress (5870) this still happens with kernel-2.6.40.6-0.fc15.x86_64.

Comment 4 Josep 2012-04-01 09:52:22 UTC
Hi,

I have the same problem with F16, also with a radeon juniper chip (HD 5770).

The system has the latest updates as of this writing, kernel is:
kernel-3.3.0-8.fc16.x86_64

When I used kernel 3.3.0-4, I could reproduce the issue 100% of the time by just maximizing an evince window (other applications did not trigger this behavior), sometimes I had to unmaximize too, but generally maximizing was enough. Resizing the window does trigger the bug too.
With the current kernel (3.3.0-8), it takes a few more iterations of maximizing/unmaximazing evince to trigger the bug, but it eventually it still happens.

I tried with other applications like firefox, eog, shotwell, gnome-terminal, etc, and I could not trigger this bug by maximizing/unmaximizing or resizing the window. Except in firefox, where it did happen once when bringing up the context menu (right click), actually when trying to fill in this comment ;-)

Another application on which I managed to trigger this bug was with darktable, but not by maximizing or resizing the window, but by expanding one of its lateral panels.

Probably the versions field of this bug should be updated to reflect F16 too.

If there is more information I can provide to help fix this issue, let me know.

Comment 5 Fedora End Of Life 2012-08-07 16:31:33 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.