Bug 727539 - Appvg on usb can't be discovered during automatic install
Appvg on usb can't be discovered during automatic install
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Alan Pevec
Virtualization Bugs
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-02 08:10 EDT by shaochen
Modified: 2016-04-26 10:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-05 00:43:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt.log (28.23 KB, text/plain)
2011-08-02 08:10 EDT, shaochen
no flags Details

  None (edit)
Description shaochen 2011-08-02 08:10:45 EDT
Created attachment 516312 [details]
ovirt.log

Description of problem:
Appvg on usb can't be discovered during automatically.

Version-Release number of selected component (if applicable):
rhev-hypervisor-6.1-20110801.0.el6_1

How reproducible:
100%

Steps to Reproduce:
1. Auto install RHEVH with "storage_init=/dev/sda;/dev/sdb storage_vol=50:5:5:50:500:500:500:500 swap_encrypt=Swap;Swap2 local_boot firstboot".
2. Execute command "lvs".
3. Execute command "pvscan"
4. Execute command "lvs".
  
Actual results:
Appvg on usb can't be discovered during automatically. 
After execute command "pvscan", Appvg on usb will be discovered.


# cat /etc/issue
Red Hat Enterprise Virtualization Hypervisor release 6.1 (20110801.0.el6_1)
Kernel \r on an \m (\l)

Please login as 'admin' to configure the node
[root@localhost ~]# lvs
  LV      VG     Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  Config  HostVG -wi-ao  52.00m                                      
  Data    HostVG -wi-ao 500.00m                                      
  Logging HostVG -wi-ao  52.00m                                      
  Swap    HostVG -wi-ao   8.00m                                      
[root@localhost ~]# pvscan 
  PV /dev/sdb1                                                                             VG AppVG    lvm2 [3.73 GiB / 2.76 GiB free]
  PV /dev/mapper/1ATA     ST3500418AS                                         5VMFG7RKp3   VG HostVG   lvm2 [465.28 GiB / 464.68 GiB free]
  Total: 2 [469.02 GiB] / in use: 2 [469.02 GiB] / in no VG: 0 [0   ]
[root@localhost ~]# lvs
  LV      VG     Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  Data2   AppVG  -wi--- 500.00m                                      
  Swap2   AppVG  -wi--- 500.00m                                      
  Config  HostVG -wi-ao  52.00m                                      
  Data    HostVG -wi-ao 500.00m                                      
  Logging HostVG -wi-ao  52.00m                                      
  Swap    HostVG -wi-ao   8.00m  


Expected results:
Appvg on usb should be discovered during automatically.

Additional info:
1. I test this issue with rhev-hypervisor-6.2-0.9.el6, install to local disk and usb device, appvg on usb shhows direct, don't need manually execute "pvscan".

2. This no such problem with below kernel command line in FC and iscsi machine.
"storage_init=/dev/sda;/dev/sdb storage_vol=50:5:5:50:500:500:500:500 swap_encrypt=Swap;Swap2 local_boot firstboot".
Comment 2 Perry Myers 2012-01-03 14:34:09 EST
Since this only was a problem on RHEL 6.1, and RHEL 6.2 did not exhibit this issue, I'd like QE to try to retest on RHEL 6.2 GA.

If this can be reproduced on RHEL 6.2 GA then we will look into it further, otherwise this is notabug.
Comment 3 shaochen 2012-01-05 00:43:37 EST
(In reply to comment #2)
> Since this only was a problem on RHEL 6.1, and RHEL 6.2 did not exhibit this
> issue, I'd like QE to try to retest on RHEL 6.2 GA.
> 
> If this can be reproduced on RHEL 6.2 GA then we will look into it further,
> otherwise this is notabug.

Test version:
rhev-hypervisor6-6.2-20111117.1.el6

Auto install RHEVH with "storage_init=/dev/sda;/dev/sdb
storage_vol=50:5:5:50:500:500:500:500 swap_encrypt=Swap;Swap2 local_boot
firstboot".

Appvg on usb can be discovered during automatically.

So close this bug as work for me with rhevh 6.2 GA build: rhev-hypervisor6-6.2-20111117.1.el6.

Note You need to log in before you can comment on or make changes to this bug.