Bug 727547 - Unable to load session snapshot when persisting events after firing the rules
Summary: Unable to load session snapshot when persisting events after firing the rules
Keywords:
Status: CLOSED DUPLICATE of bug 724796
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRE (Expert, Fusion)
Version: BRMS 5.2.0-ER1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: BRMS 5.2.0.GA
Assignee: Mark Proctor
QA Contact: Tomas Schlosser
URL:
Whiteboard:
Depends On:
Blocks: BRMS-636
TreeView+ depends on / blocked
 
Reported: 2011-08-02 12:34 UTC by Tomas Schlosser
Modified: 2011-08-18 04:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 17:23:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomas Schlosser 2011-08-02 12:34:44 UTC
Description of problem:
When I insert an event into knowledge session received from JPAKnowledgeService and reload the session, everything is fine but when I insert event, fire rules and try to reload the session I get error with root NullPointerException.


Steps to Reproduce:
1. insert event
2. fire rules
3. call JPAKnowledgeService.loadStatefulKnowledgeSession
  
Actual results:
long stacktrace

Expected results:
reloaded session

Additional info:
java.lang.reflect.InvocationTargetException
org.drools.persistence.jpa.KnowledgeStoreServiceImpl.buildCommanService(KnowledgeStoreServiceImpl.java:103)
at org.drools.persistence.jpa.KnowledgeStoreServiceImpl.loadStatefulKnowledgeSession(KnowledgeStoreServiceImpl.java:71)
at org.drools.persistence.jpa.JPAKnowledgeService.loadStatefulKnowledgeSession(JPAKnowledgeService.java:131)
at org.jboss.qa.drools.features.PersistenceTest.testCEP(PersistenceTest.java:210)
25 lines not shown

Caused by null
sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
at org.drools.persistence.jpa.KnowledgeStoreServiceImpl.buildCommanService(KnowledgeStoreServiceImpl.java:88)
at org.drools.persistence.jpa.KnowledgeStoreServiceImpl.loadStatefulKnowledgeSession(KnowledgeStoreServiceImpl.java:71)
at org.drools.persistence.jpa.JPAKnowledgeService.loadStatefulKnowledgeSession(JPAKnowledgeService.java:131)
at org.jboss.qa.drools.features.PersistenceTest.testCEP(PersistenceTest.java:210)
25 lines not shown

Caused by Unable to load session snapshot
org.drools.persistence.SessionMarshallingHelper.loadSnapshot(SessionMarshallingHelper.java:96)
at org.drools.persistence.SingleSessionCommandService.initKsession(SingleSessionCommandService.java:193)
at org.drools.persistence.SingleSessionCommandService.<init>(SingleSessionCommandService.java:157)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
at org.drools.persistence.jpa.KnowledgeStoreServiceImpl.buildCommanService(KnowledgeStoreServiceImpl.java:88)
at org.drools.persistence.jpa.KnowledgeStoreServiceImpl.loadStatefulKnowledgeSession(KnowledgeStoreServiceImpl.java:71)
at org.drools.persistence.jpa.JPAKnowledgeService.loadStatefulKnowledgeSession(JPAKnowledgeService.java:131)
at org.jboss.qa.drools.features.PersistenceTest.testCEP(PersistenceTest.java:210)
25 lines not shown

Caused by null
org.drools.reteoo.LeftTupleImpl.<init>(LeftTupleImpl.java:164)
at org.drools.reteoo.LeftTupleImpl.<init>(LeftTupleImpl.java:150)
at org.drools.marshalling.impl.InputMarshaller.readLeftTuple(InputMarshaller.java:498)
at org.drools.marshalling.impl.InputMarshaller.readFactHandles(InputMarshaller.java:373)
at org.drools.marshalling.impl.InputMarshaller.readSession(InputMarshaller.java:221)
at org.drools.marshalling.impl.DefaultMarshaller.unmarshall(DefaultMarshaller.java:92)
at org.drools.persistence.SessionMarshallingHelper.loadSnapshot(SessionMarshallingHelper.java:91)
at org.drools.persistence.SingleSessionCommandService.initKsession(SingleSessionCommandService.java:193)
at org.drools.persistence.SingleSessionCommandService.<init>(SingleSessionCommandService.java:157)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
at org.drools.persistence.jpa.KnowledgeStoreServiceImpl.buildCommanService(KnowledgeStoreServiceImpl.java:88)
at org.drools.persistence.jpa.KnowledgeStoreServiceImpl.loadStatefulKnowledgeSession(KnowledgeStoreServiceImpl.java:71)
at org.drools.persistence.jpa.JPAKnowledgeService.loadStatefulKnowledgeSession(JPAKnowledgeService.java:131)
at org.jboss.qa.drools.features.PersistenceTest.testCEP(PersistenceTest.java:210)
25 lines not shown

Comment 1 Tihomir Surdilovic 2011-08-17 17:23:07 UTC

*** This bug has been marked as a duplicate of bug 724796 ***


Note You need to log in before you can comment on or make changes to this bug.