Bug 727553 - yum --skip-broken never ending dependency resolution
Summary: yum --skip-broken never ending dependency resolution
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 12:54 UTC by Petr Beňas
Modified: 2015-01-04 23:01 UTC (History)
3 users (show)

Fixed In Version: yum-3.2.29-31.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:12:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0406 normal SHIPPED_LIVE yum bug fix and enhancement update 2013-02-20 20:50:44 UTC

Description Petr Beňas 2011-08-02 12:54:33 UTC
Description of problem:
yum --skip-broken dependency resolution never ends.

Version-Release number of selected component (if applicable):
yum-3.2.29-17.el6.noarch

How reproducible:
100% on my laptop. Bug guess it's dependent to repo's used and packages installed.

Steps to Reproduce:
pbenas@dhcp-29-193:~$ rpm -qa yum rpm
yum-3.2.29-17.el6.noarch
rpm-4.8.0-16.el6.x86_64
pbenas@dhcp-29-193:~$ head -n 6 /etc/yum.repos.d/rhel.repo 
[rhel]
name=Red Hat Enterprise Linux $releasever - $basearch
baseurl=http://download.devel.redhat.com/nightly/latest-RHEL6.2/6.2/Workstation/$basearch/os
enabled=1
gpgcheck=0

pbenas@dhcp-29-193:~$ sudo yum update --disablerepo=\* --enablerepo=rhel 
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package virt-manager.noarch 0:0.8.6-4.el6 will be updated
---> Package virt-manager.x86_64 0:0.9.0-3.el6 will be an update
---> Package xulrunner.x86_64 0:1.9.2.18-2.el6_1 will be updated
---> Package xulrunner.x86_64 0:5.0-2.el6 will be an update
--> Processing Conflict: firefox-3.6.18-1.el6_1.x86_64 conflicts xulrunner >= 1.9.2.19
--> Finished Dependency Resolution
Error: firefox conflicts with xulrunner
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
pbenas@dhcp-29-193:~$ sudo yum update --disablerepo=\* --enablerepo=rhel --skip-broken
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package virt-manager.noarch 0:0.8.6-4.el6 will be updated
---> Package virt-manager.x86_64 0:0.9.0-3.el6 will be an update
---> Package xulrunner.x86_64 0:1.9.2.18-2.el6_1 will be updated
---> Package xulrunner.x86_64 0:5.0-2.el6 will be an update
--> Processing Conflict: firefox-3.6.18-1.el6_1.x86_64 conflicts xulrunner >= 1.9.2.19
--> Finished Dependency Resolution
--> Running transaction check
---> Package virt-manager.noarch 0:0.8.6-4.el6 will be updated
---> Package virt-manager.x86_64 0:0.9.0-3.el6 will be an update
---> Package xulrunner.x86_64 0:1.9.2.18-2.el6_1 will be updated
---> Package xulrunner.x86_64 0:5.0-2.el6 will be an update
--> Processing Conflict: firefox-3.6.18-1.el6_1.x86_64 conflicts xulrunner >= 1.9.2.19
--> Finished Dependency Resolution
--> Running transaction check
.
.
.
keeps printing the same again and again

  
Actual results:
Never ending package dependency resolution.


Expected results:
Seems like packages has wrong dependencies. But this should be detected and dependency resolution should finish. 


Additional info:
Workaronud: using -x <problematic package> instead of --skip-broken

Comment 2 James Antill 2011-08-02 16:57:00 UTC
Can you try the rawhide rebuild yum? I know a bunch of skip-broken patches have gone in, so it's very possibly fixed.

Comment 3 Petr Beňas 2011-08-03 08:11:10 UTC
I tried to install latest rawhide yum (yum-3.4.3-5.fc17.noarch.rpm) to my RHEL6 laptop, but it requires Python 2.7, which seems to be a bit hard to install to RHEL6. There is no python-2.7 for RHEL6 and attempt to to install rawhide python-2.7 brings me to dependency hell, since a lot of packages are python-dependent. I'd need to almost update my laptop to Fedora rawhide, what I don't want to and also the bug is RHEL6 repo dependent, I guess.

I've considered manual python-2.7 compilation, but this probably would not solve this problem, since this is about rpm dependency, right?
Building yum-3.4.3-5 rhel6 package without python-5.7 dependency neither seems possible to me.
Any other options I've forgot and worth to trying?

Comment 4 James Antill 2011-08-03 19:03:12 UTC
No, sorry, you want the _rebuild_ of rawhide yum, for RHEL-6:

http://repos.fedorapeople.org/repos/james/yum-rawhide/epel-yum-rawhide.repo

Comment 5 Petr Beňas 2011-08-04 08:28:08 UTC
yum-3.4.3-4.el6.noarch fixes this bug.


pbenas@dhcp-29-193:~$ sudo yum update yum --disablerepo=\* --enablerepo=epel-yum-rawhide
Loaded plugins: presto, refresh-packagekit
epel-yum-rawhide                                                               | 2.8 kB     00:00     
epel-yum-rawhide/primary_db                                                    |  19 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package yum.noarch 0:3.2.29-17.el6 will be updated
---> Package yum.noarch 0:3.4.3-4.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================
 Package          Arch                Version                     Repository                     Size
======================================================================================================
Updating:
 yum              noarch              3.4.3-4.el6                 epel-yum-rawhide              1.0 M

Transaction Summary
======================================================================================================
Upgrade       1 Package(s)

Total download size: 1.0 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
epel-yum-rawhide/prestodelta                                                   | 1.1 kB     00:00     
Processing delta metadata
Package(s) data still to download: 1.0 M
yum-3.4.3-4.el6.noarch.rpm                                                     | 1.0 MB     00:08     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : yum-3.4.3-4.el6.noarch                                                             1/2 
  Cleanup    : yum-3.2.29-17.el6.noarch                                                           2/2 

Updated:
  yum.noarch 0:3.4.3-4.el6                                                                            

Complete!
pbenas@dhcp-29-193:~$ sudo yum update --disablerepo=\* --enablerepo=rhel
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package virt-manager.noarch 0:0.8.6-4.el6 will be updated
---> Package virt-manager.x86_64 0:0.9.0-3.el6 will be an update
---> Package xulrunner.x86_64 0:1.9.2.18-2.el6_1 will be updated
---> Package xulrunner.x86_64 0:5.0-2.el6 will be an update
--> Processing Conflict: firefox-3.6.18-1.el6_1.x86_64 conflicts xulrunner >= 1.9.2.19
--> Finished Dependency Resolution
Error: firefox conflicts with xulrunner-5.0-2.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
pbenas@dhcp-29-193:~$ sudo yum update --disablerepo=\* --enablerepo=rhel --skip-broken
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package virt-manager.noarch 0:0.8.6-4.el6 will be updated
---> Package virt-manager.x86_64 0:0.9.0-3.el6 will be an update
---> Package xulrunner.x86_64 0:1.9.2.18-2.el6_1 will be updated
---> Package xulrunner.x86_64 0:5.0-2.el6 will be an update
--> Processing Conflict: firefox-3.6.18-1.el6_1.x86_64 conflicts xulrunner >= 1.9.2.19
--> Running transaction check
---> Package virt-manager.noarch 0:0.8.6-4.el6 will be updated
---> Package virt-manager.x86_64 0:0.9.0-3.el6 will be an update
--> Running transaction check
---> Package virt-manager.noarch 0:0.8.6-4.el6 will be updated
---> Package virt-manager.x86_64 0:0.9.0-3.el6 will be an update
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    xulrunner-5.0-2.el6.x86_64 from rhel

Dependencies Resolved

======================================================================================================
 Package                    Arch                 Version                     Repository          Size
======================================================================================================
Updating:
 virt-manager               x86_64               0.9.0-3.el6                 rhel               1.0 M
Skipped (dependency problems):
 xulrunner                  x86_64               5.0-2.el6                   rhel                10 M

Transaction Summary
======================================================================================================
Upgrade       1 Package

Total download size: 1.0 M
Is this ok [y/N]:

Comment 6 RHEL Product and Program Management 2011-10-07 16:20:10 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Jan Zeleny 2012-09-07 12:25:44 UTC
James, since the rawhide build fixes the issue, could you evaluate if we can get the fix to 6.4?

Comment 8 James Antill 2012-09-20 15:29:16 UTC
We'll rebase the skip-broken code ... but that is pretty self contained, basically replacing a function. Should be safe.

Comment 13 errata-xmlrpc 2013-02-21 10:12:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0406.html


Note You need to log in before you can comment on or make changes to this bug.