Bug 727563 - admin password is set to rootpw instead of adminpw parameter
Summary: admin password is set to rootpw instead of adminpw parameter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 13:15 UTC by Guohua Ouyang
Modified: 2011-12-06 19:25 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-2.0.2-0.1.git5dce5f9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:25:48 UTC


Attachments (Terms of Use)
Patch (910 bytes, patch)
2011-08-04 17:21 UTC, Mike Burns
no flags Details | Diff
Followup (880 bytes, patch)
2011-08-08 18:17 UTC, Mike Burns
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Guohua Ouyang 2011-08-02 13:15:29 UTC
Description of problem:
Auto install with adminpw, after reboot and logon with admin, it does not prompt old passwd.


#
Please login as 'admin' to configure the node                                   
localhost.localdomain login: admin                                              
You are required to change your password immediately (root enforced)            
New password: 



Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-09.el6

How reproducible:
Always.

Steps to reproduce:
1. Auto install with adminpw=123.
2. Reboot and logon with admin

Actual results:
Did not prompt old passwd for adminpw before change new passwd.

Expected results:
Before change new passwd, it should prompt old passwd first.

Comment 2 Mike Burns 2011-08-04 17:21:15 UTC
Created attachment 516750 [details]
Patch

Problem was that the code was setting the admin password to be the value of rootpw instead of adminpw.  

Testing:  

Verify it prompts for admin before letting you change on first login

Comment 3 Mike Burns 2011-08-08 18:08:54 UTC
Moving back to Assigned to add the following change:

if rootpw is passed and adminpw is not passed, then set admin passwd to be rootpw

Comment 4 Mike Burns 2011-08-08 18:17:26 UTC
Created attachment 517270 [details]
Followup

Testing:

Pass different rootpw and adminpw, ensure that both logins work
pass only rootpw, ensure that login as admin works
pass only adminpw, ensure that login as admin works


Note:  

Resetting password for admin on first login will no set the password for root.  They still will need to be reset individually.

Comment 6 Guohua Ouyang 2011-08-26 09:10:33 UTC
Verified on 6.2-0.14:
1. set adminpw=xxx during install.
2. after install, login with admin.
3. prompt current password first, then can set new password.

Comment 7 errata-xmlrpc 2011-12-06 19:25:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.