Bug 727586 - repodiff uses stale metadata cache in subsequent runs
repodiff uses stale metadata cache in subsequent runs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.3
All All
high Severity high
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On: 665919 709972
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-02 10:28 EDT by James Antill
Modified: 2014-01-21 01:24 EST (History)
1 user (show)

See Also:
Fixed In Version: yum-3.2.29-18.el6
Doc Type: Bug Fix
Doc Text:
Previously, the repodiff utility used a stale metadata cache in subsequent runs. When two repodiff commands were executed in succession, the second run reused cached data from the first. This bug has been fixed and repodiff now properly validates the metadata if a connection cannot be established or the cached data are about to be reused.
Story Points: ---
Clone Of: 709972
Environment:
Last Closed: 2011-12-06 12:34:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 3 Jaromir Hradilek 2011-10-26 11:26:36 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the repodiff utility used a stale metadata cache in subsequent runs. When two repodiff commands were executed in succession, the second run reused cached data from the first. This bug has been fixed and repodiff now properly validates the metadata if a connection cannot be established or the cached data are about to be reused.
Comment 4 errata-xmlrpc 2011-12-06 12:34:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1702.html

Note You need to log in before you can comment on or make changes to this bug.